Reply to topic

Nvidia users: switch your Qt graphicssystem

User avatar Vortex375
Registered Member
Posts
102
Karma
0
OS
If your KDE apps feel slow and sluggish (which is most likely the case if you are using an Nvidia card) I can really recommend to change Qt's graphics system.

I'm using an Nvidia GeForce 9800 GTX and KDE runs so much faster when using the Raster backend rather than the supposedly "hardware-accelerated" Native backend.

For example, try scrolling in dolphin. Open a folder with a lot of files, then drag the scroll bar handle (it's especially slow in the "Details" view mode).
Quit dolphin (!) then open konsole and start dolphin with "dolphin -graphicssystem raster". Now, try the same thing again. It's awesome, isn't it? :)
You should also try resizing the window!

Here is a KDE Control Module that can change the default graphics system for you: http://kde-apps.org/content/show.php/KCM+Qt+Graphics+System?content=129817

Note that you need at least Qt 4.7 to be able to change the graphics system.

You can also manually create a script file in ~/.kde4/env. Name it e.g. "qt-graphicssystem.sh" (or something else) and paste this into it:
Code: Select all
export QT_GRAPHICSSYSTEM=raster


You have to log out and log in again for changes to take effect.

Now, enjoy your lightning-fast KDE. ;D (Okay, it's still slow compared to 3.5, but...)
User avatar google01103
Manager
Posts
4964
Karma
17
OS
Interesting - have you tried the openGL backend? though old this article implies it is much faster http://labs.qt.nokia.com/2008/10/22/so- ... -the-blit/

update - tried openGL backend and nothing but issues - errors when starting kde (print server and another), errors when changing workspace appearance (a kde window popups on bottom left with no text), screen filled with tiny dots, plasma not showing icons on taskbar.


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
User avatar google01103
Manager
Posts
4964
Karma
17
OS
Went back to default (from raster) as some icons (notifier, krunner toolbar) not showing - of course ymmv


OpenSuse 13.1 x64, KDE 4.12.x

Problem solved? Please click on Image below the post with the best answer to mark your topic as solved.
barghest
Registered Member
Posts
48
Karma
0
OS
Hmm..yes raster makes everything runs smooth, but since I activated it the fan of my 7600GT is running all the time which is very annoying. Anything I can do about that?
User avatar superori
Registered Member
Posts
7
Karma
0
OS
Open Office doesn't work on KDE with Raster :(

Well, you can remove the openoffice-kde package but Open Office applications will look so ugly without KDE integration.
dimitar
Registered Member
Posts
32
Karma
0
OS
Does anyone know, why this problem occurs with the nvidia driver? Did they not implement something from the 2D acceleration in X, or...?
User avatar TheBlackCat
Registered Member
Posts
2945
Karma
8
OS
Thanks, superori, that fixes the openoffice crashes I have been having. Is there a way to disable raster graphics just for openoffice?


Man is the lowest-cost, 150-pound, nonlinear, all-purpose computer system which can be mass-produced by unskilled labor.
-NASA in 1965
User avatar Vortex375
Registered Member
Posts
102
Karma
0
OS
Should work if you either start Open Office from a console window or edit your Open Office button. Use this command:
Code: Select all
QT_GRAPHICSSYSTEM=native ooffice


The fan speed problem is very strange. Did you open nvidia-settings and check your performance settings and temperature?
nerdy_kid
Registered Member
Posts
54
Karma
0
OS
This helped out A LOT, apps do seem to crash a little more often, worth the speed boost though. Does anyone have an idea to automatically have all gtk apps use the native qt rendering? Raster breaks gtk-qt style (open office uses that I am pretty sure) which I like very much.

[edit]
sorry did not mean to bump this...
amas
Registered Member
Posts
1
Karma
0
OS
You can make certain apps automatically use the native rendering by editing them in the menu editor.

Right click on the KDE menu and then select 'Menu Editor'. Select the app you want to use native rendering with and append to the start of the command entry:
Code: Select all
QT_GRAPHICSSYSTEM=native

so that for open office writer the command looks like this:
Code: Select all
QT_GRAPHICSSYSTEM=native oowriter %U


Hope that helps
nerdy_kid
Registered Member
Posts
54
Karma
0
OS
amas wrote:You can make certain apps automatically use the native rendering by editing them in the menu editor.

Right click on the KDE menu and then select 'Menu Editor'. Select the app you want to use native rendering with and append to the start of the command entry:
Code: Select all
QT_GRAPHICSSYSTEM=native

so that for open office writer the command looks like this:
Code: Select all
QT_GRAPHICSSYSTEM=native oowriter %U


Hope that helps


I actually found oxygen-gtk (http://gitorious.org/oxygen-gtk) which fixed my problem. It looks way better then qt-gtk, and is fine with me using raster.
User avatar TheBlackCat
Registered Member
Posts
2945
Karma
8
OS
Can you explain exactly what you did to get this working?


Man is the lowest-cost, 150-pound, nonlinear, all-purpose computer system which can be mass-produced by unskilled labor.
-NASA in 1965
User avatar mrbumpy409
Registered Member
Posts
7
Karma
0
OS
The raster engine makes no discernible difference when using QtCurve, but makes a huge impact on the performance of the Oxygen theme. I read somewhere that Oxygen uses some graphics features that the NVIDIA binary driver is terribly slow at.

My solution: use the QtCurve theme engine instead of Oxygen. It is much faster than Oxygen on NVIDIA, and you won't have the glitches and problems that show up with the raster drawing mode. Here's a nice QtCurve theme to start off with:
http://kde-look.org/content/show.php/CurveDomina+Qtcurve?content=126954
zephyr
Registered Member
Posts
7
Karma
0
OS
TheBlackCat wrote:Is there a way to disable raster graphics just for openoffice?


Try adding the following to the file /usr/lib/ooo-3.3/program/soffice (or /usr/bin/soffice that symlinks to it):

QT_GRAPHICSSYSTEM=native
export QT_GRAPHICSSYSTEM

Depending on your distro libre/openoffice could be installed in another prefix e.g /opt.
hellslinger
Registered Member
Posts
1
Karma
0
OS
Oxygen went from being slow to being very very snappy on my 9800. Thank you so much!

 
Reply to topic

Bookmarks



Who is online

Registered users: ab4bd, Baidu [Spider], BeS, Bing [Bot], Exabot [Bot], GeekQuack, ggael, ghevan, Google [Bot], google01103, igorm, jensreuterberg, kainz.a, maarten, mmistretta, Nuc!eoN, orbmiser, plfiorini, scummos, searchfgold6789, SecretCode, Steve T, TheraHedwig, Uri_Herrera, vblazquez, Yahoo [Bot]