Reply to topic

kopete: How to ignore the KDE colours?

User avatar daihard
Registered Member
Posts
71
Karma
0
OS
Distribution: Kubuntu 10.10
KDE Version: 4.5.5
-------------------

Hi.

Is there a way for kopete to NOT use the KDE colours specified in the System Settings? I am asking because kopete does not convert my chat buddy's text to match the KDE colours. For instance if I use "Obsidian Coast," the default text colour will be white. However, if someone whose text is normally black starts a chat with me, kopete won't change his/her text to white, thereby making their conversations totally invisible. I don't want to change my KDE theme colours just for kopete.

So I can think of two solutions - 1) Let kopete force the KDE colours on the chat buddy's conversations, or 2) Let it ignore the KDE colours and fall back on the plain white-background scheme. Is either possible?

Thanks in advance for your help!


Kubuntu 12.04 (Precise Pangolin) 64-bit / KDE 4.8.1
Work: Dell Precision T5500 (Xeon E5506 @ 2.13 GHz x 2 / 12GB RAM)
Home: Panasonic Toughbook W8 (Core 2 Duo @ 1.20 GHz / 4GB RAM)
User avatar bcooksley
Administrator
Posts
18601
Karma
83
OS
The usage of non-colour scheme compliant colours for text should be considered as a bug. However, your contact's clients may be themselves broken, by sending explicit text colours along with their message, which KDE would then be required to respect.


System Settings and Device Actions KCM maintainer
Image
User avatar daihard
Registered Member
Posts
71
Karma
0
OS
bcooksley wrote:The usage of non-colour scheme compliant colours for text should be considered as a bug. However, your contact's clients may be themselves broken, by sending explicit text colours along with their message, which KDE would then be required to respect.


Thanks for the reply.

In that case, it may be useful to have an "override" mode that ignores the request coming from the buddy. Kopete doesn't have control over what it receives, but it can control how it displays the text they send, if necessary.

Do you think it's worth submitting a feature request?


Kubuntu 12.04 (Precise Pangolin) 64-bit / KDE 4.8.1
Work: Dell Precision T5500 (Xeon E5506 @ 2.13 GHz x 2 / 12GB RAM)
Home: Panasonic Toughbook W8 (Core 2 Duo @ 1.20 GHz / 4GB RAM)
User avatar bcooksley
Administrator
Posts
18601
Karma
83
OS
In this case it may be. Regardless of which one of the methods is the case, one is a bug, the other is a feature request.


System Settings and Device Actions KCM maintainer
Image
User avatar daihard
Registered Member
Posts
71
Karma
0
OS
bcooksley wrote:In this case it may be. Regardless of which one of the methods is the case, one is a bug, the other is a feature request.

Thanks again.

I've actually found that another chat client, pidgin, does have the option to ignore the format of the incoming messages. It'd be nice to be able to use kopete, but for now pidgin will have to do.


Kubuntu 12.04 (Precise Pangolin) 64-bit / KDE 4.8.1
Work: Dell Precision T5500 (Xeon E5506 @ 2.13 GHz x 2 / 12GB RAM)
Home: Panasonic Toughbook W8 (Core 2 Duo @ 1.20 GHz / 4GB RAM)

 
Reply to topic

Bookmarks



Who is online

Registered users: Alexa [Bot], Baidu [Spider], Bing [Bot], bshah, cylverbak, dehnhardt, Exabot [Bot], ggael, Google [Bot], HmpfCBR, ivan, ken300, koriun, Majestic-12 [Bot], nezumi, ooker, oskaras, paulus3005, rulet111, Schoelje, TheraHedwig, Tuukka, valoriez, VulpesVulpes, Yahoo [Bot]