Reply to topic

How to get good KDE speed with bad hardware acceleration

Gullible Jones
Registered Member
Posts
121
Karma
0
OS
(Or rather, with no hardware acceleration at all.)

Put something like this in as the Device section of your xorg.conf:

Code: Select all
Section "Device"
    Identifier "Card0"
    Driver "vesa"
    Option "ShadowFB" "on"
EndSection


Yes, this enables the vesa driver, and will disable all 2D (and usually all 3D) acceleration. The important part is the "ShadowFB" option, which tells the CPU to render images in main RAM before putting them in video memory.

In addition to making KDE4 snappier, this also seems to make Flash video playback smoother and less CPU intensive.

I don't know why this should work - it looks as though it shouldn't - but I'm guessing it's because the Linux accelerated graphics stack is in a really bad way. At any rate, it's nothing I'd recommend for anyone with a fancy, expensive video card... But if you have the usual Intel or VIA rubbish, and don't play any 3D games, you might want to see if it works for you; especially if you have a fast CPU.

Edit: also, I'm finding that on some computers the fbdev driver works better. In that case, substitute "fbdev" for "vesa" in the above xorg.conf section, and make sure the Linux framebuffer is enabled. Be warned that with fbdev, you won't be able to change your display resolution or refresh rate.

Reply to topic

Bookmarks



Who is online

Registered users: Alexa [Bot], Baidu [Spider], Bing [Bot], bshah, Exabot [Bot], Google [Bot], grubaugh, Hans, Naver Yeti [Spider], onesandzeros, orbmiser, pedrorodriguez, pvonz, qwach, searchfgold6789, Uri_Herrera, Yahoo [Bot]