This forum has been archived. All content is frozen. Please use KDE Discuss instead.

(Debian) Sometimes typing practically doesn't work in Plasma

Tags: None
(comma "," separated)
Registered Member

After some time, it becomes impossible to type correctly in Plasma (on the desktop, in the searchbar of the application launcher). I always manage to type one character right away, then I can only type after hitting a key up to thirty times.

I can style use the keypad to move in the application launcher or to select folders on the desktop. Other softwares are not impacted at all. The problem disappears after logging out and in.

I use a Logitech K310 but I tried using my HP KU-0841 and it made no difference. I also reset to default the keyboard settings in the system settings and tried choosing generic keyboard settings, without results.

I may have the same problem as this person this person but I used Kubuntu too, and my problem started a few days ago, when I switched to Debian.

My config:

Code: Select all
System:    Host: Melchizedek Kernel: 4.9.0-5-amd64 x86_64 (64 bit gcc: 6.3.0)
           Desktop: KDE Plasma 5.8.6 (Qt 5.7.1) Distro: Debian GNU/Linux 9 (stretch)
Machine:   Device: desktop System: Hewlett-Packard product: p6710fr v: xxx0204GRxxxxxxxx0
           Mobo: MSI model: 2A9C v: 1.1 BIOS: American Megatrends v: 6.14 date: 11/05/2010
CPU:       Dual core Intel Core i3 550 (-HT-MCP-) cache: 4096 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 12769
           clock speeds: max: 3200 MHz 1: 1333 MHz 2: 1733 MHz 3: 1733 MHz 4: 2667 MHz
Graphics:  Card: NVIDIA GT218 [GeForce 405] bus-ID: 01:00.0
           Display Server: X.Org 1.19.2 drivers: nouveau (unloaded: modesetting,fbdev,vesa)
           Resolution: 1920x1080@59.93hz
           GLX Renderer: Gallium 0.4 on NVA8 GLX Version: 3.0 Mesa 13.0.6 Direct Rendering: Yes
Audio:     Card-1 Intel 5 Series/3400 Series High Definition Audio driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 NVIDIA High Definition Audio Controller driver: snd_hda_intel bus-ID: 01:00.1
           Sound: Advanced Linux Sound Architecture v: k4.9.0-5-amd64
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d800 bus-ID: 02:00.0
           IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-2: Ralink RT3090 Wireless 802.11n 1T/1R PCIe driver: rt2800pci v: 2.3.0 bus-ID: 04:00.0
           IF: wlp4s0 state: down mac: <filter>
Drives:    HDD Total Size: 2320.5GB (13.1% used)
           ID-1: /dev/sda model: WDC_WD20EARS size: 2000.4GB temp: 0C
           ID-2: USB /dev/sdb model: 3200BEV_External size: 320.1GB temp: 0C
Partition: ID-1: / size: 1.8T used: 279G (17%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 6.30GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
Sensors:   System Temperatures: cpu: 47.0C mobo: N/A gpu: 50.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 200 Uptime: 6:37 Memory: 2481.5/5834.7MB Init: systemd runlevel: 5 Gcc sys: 6.3.0
           Client: Shell (bash 4.4.121) inxi: 2.3.5
Registered Member

I have the same problem. I can't type correctly on the desktop but I can on the other applications.
I have to restart the computer to solve it.

My configuration:
Debian GNU/Linux 9
KDE Plasma Version: 5.8.6
KDE Frameworks Version: 5.28.0
Qt Version: 5.7.1
Kernel Version: 4.9.0-8-amd64
OS Type: 64-bit

Processors: 4 x Intel Core i5-6200U CPU @2.30GHz
Memory: 7.7 GiB of RAM
User avatar
Sorry, but I suggest upgrading, you sue a very old Plasma version, current is 5.18.2, even Debian has newer ones

Running Kubuntu 22.10 with Plasma 5.26.3, Frameworks 5.100.0, Qt 5.15.6, kernel 5.19.0-23 on Ryzen 5 4600H, AMD Renoir, X11
FWIW: it's always useful to state the exact Plasma version (+ distribution) when asking questions, makes it easier to help ...


Who is online

Registered users: Bing [Bot], Google [Bot], kesang, Yahoo [Bot]