This forum has been archived. All content is frozen. Please use KDE Discuss instead.

Dual touch-pad config settings fail

Tags: None
(comma "," separated)
Registered Member

Dual touch-pad config settings fail

Fri Jun 26, 2020 12:35 pm

wish you all are well.

I am running Kubuntu 20.04 LTS on dell precision workstation M7520 which is a laptop. Plasma v5.18.5 framework 5.68.0 qt 5.12.8 kernel 5.4.0-39

I installed kubuntu looking for a better desktop, used budgie for a long while, but there was some issues. Using Dell Dock TB16 with two displays. Happy now in Kubuntu, I got a new USB touchpad I wanted to config it via KDE settings. Well, some things happened along the way:

At the very beginning I did not see my usb touch-pad (HAILUCK CO.,LTD Usb Touch Touchpad) on the pull-down list of touchpad devices. Only the built-in from my laptop (Fibocom DLL07B0:01 044E:120B). First impression was that the new hardware was not recognized, even though it worked. I went back to my budgie desktop ( still have it updated and running on the same laptop in separate hard disk, just in case!! ) and both devices worked well simultaneously, even with libinput-gestures and gestures applications (You can set them to work on all devices).

After a trial and error process (not much documentation on this matter) I now know that depending on the xserver-xorg-input package installed, I get a basic screen settings ( libinput only) or a more comprehensive multiple tab config (libinput+synaptics) but still I am not able to enable the device pull-down list to work. it is always greyed-out.

With that pull-down list I would be able to config each touch-pad separately, as both have different parameters given the working config( Undocked, one screen with dell touch-pad. Docked, Two screens mouse+usb touch-pad). Experience is not smooth because every reboot all settings revert to default. I have to disable the built-in touch-pad (on the icon on the system tray) to make changes stick on the usb touch-pad. On undock I have to re-enable the built-in touch-pad, causing config to be lost for the usb touch-pad. Settings established either using libinput only or libinput+synaptics are lost every time I shut down or dock/undock.

I cannot get rid on libinput as this is the only way to be able to use gestures, if this were the solution.Tried all other alternatives (Mtrack, multitouch, evdev) but synaptics is the only option which recognizes both touch-pads. Managed to get the usb touch-pad on the pulldown list by manually disabling the built-in touch-pad.

Followed libinput + xinput troubleshooting and finally got both touch-pads working, with natural scroll, and gestures (three and four finger), by creating additional xorg config files inside /usr/share/X11/xorg.conf.d/ (Disabled dual point stick, enabled natural scroll, established acceleration for both touch-pads, etc), so I am now comfortable. Ended up for now just using libinput and fined tuned setting in xorg config files. Nevertheless, pull-down list does not work. If I could make it work ( the pull-down list), I could try setting each touchpad, and remove the fixed settings in xorg files. For now, this is the only way to avoid setting things up every boot or dock/undock.

This should not be the way KDE config works. if there is a pulldown list, you should be able to pull it down and select the different options. Any ideas why the pull-down does not work? Why settings do not stick?

Any hep will be appreciated, Thanks and be safe!

Registered Member
Bump, same issue. My Synaptics touchpad was working perfectly, configured in systemsettings -> touchpad. That checkbox ticked, I moved on to configure my Wacom tablet and enabled the libinput driver. That now works perfectly, but as a result my touchpad config is broken...

I also don't understand why there is a 'Device' drop-down in the Touchpad section of settings but it is greyed out. Is it a bug or a work in progress? It's not an issue with the libinput driver, as both Wacom tablet and touchpad can be configured to work at the same time using xinput.


Who is online

Registered users: bartoloni, Bing [Bot], Google [Bot], Sogou [Bot], Yahoo [Bot]