This forum has been archived. All content is frozen. Please use KDE Discuss instead.

setxkbmap doesn't work well

Tags: None
(comma "," separated)
Registered Member

setxkbmap doesn't work well

Tue May 03, 2022 3:35 am
Hello, I'm trying to configure the keyboard in i3. I want to switch the keyboard layout to right control.
I enter the command in the terminal:
Code: Select all
setxkbmap -model pc104 -layout us,ru -option grp:rctrl_toggle

The available keyboard shortcuts are obtained by the command:
Code: Select all
localectl list-x11-keymap-options

After application, the output of the command became the following, it is clear that this setting was registered in the options:
Code: Select all
setxkbmap -print -verbose 10

Code: Select all
Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev...
Trying to load rules file /usr/share/X11/xkb/rules/evdev...
Applied rules from evdev:
rules:      evdev
model:      pc104
layout:     us,ru
options:    grp:alt_shift_toggle,grp:ctrl_alt_toggle
Trying to build keymap using the following components:
keycodes:   evdev+aliases(qwerty)
types:      complete
compat:     complete
symbols:    pc+us+ru:2+inet(evdev)+group(ctrl_alt_toggle)+group(alt_shift_toggle)
geometry:   pc(pc104)
xkb_keymap {
   xkb_keycodes  { include "evdev+aliases(qwerty)"   };
   xkb_types     { include "complete"   };
   xkb_compat    { include "complete"   };
   xkb_symbols   { include "pc+us+ru:2+inet(evdev)+group(ctrl_alt_toggle)+group(alt_shift_toggle)"   };
   xkb_geometry  { include "pc(pc104)"   };

Changing the layout works on alt_shift, after entering the command:
Code: Select all
setxkbmap -model pc104 -layout us,ru -option grp:alt_shift_toggle

Before that, I upgraded kubuntu from 20.04 lts to 22.04 lts and the kernel. Maybe it's related to this, because the setting in the i3 config also stopped working. But I'm not sure because I don't know if it's related or not.
Code: Select all
exec --no-startup-id "setxkbmap -model pc104 -layout us,ru -option grp:alt_shift_toggle"

I prescribed the autorun of this command in .xinitrc, doesn't work either:
Code: Select all
setxkbmap -model pc104 -layout us,ru -option grp:alt_shift_toggle

Tried to configure the Xorg config /etc/X11/xorg.conf.d/00-keyboard.conf
Code: Select all
# /etc/X11/xorg.conf.d/00-keyboard.conf
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "us,ru"
        Option "XkbModel" "pc104"
        Option "XkbOptions" "grp:alt_shift_toggle"

Set up parameters in в /etc/default/keyboard:
Code: Select all
# /etc/default/keyboard


I don't know where to dig anymore. :(


Who is online

Registered users: Bing [Bot], Evergrowing, Google [Bot], rblackwell