This forum has been archived. All content is frozen. Please use KDE Discuss instead.

Fish, ssh, ftp "Could not connect to host" problem

Tags: None
(comma "," separated)
Registered Member
Hi -

I would like to share files on my local network (LAN, correct?) and I can't get fish, ftp, or ssh to work.

I'm running Linux Mint 17.1 KDE on two machines in my home. They are both connected to a Linksys WRT-54GL running the stock firmware. Yes, I've secured the wireless, although, while attempting to get the two machines talking to one another, I've hardwired both to the router via Ethernet cables.

As you can likely tell already, I know next to nothing about networks.

Also, I've disabled the firewalls I setup on both machines so blocked ports would not interfere with my network attempts. CODE: sudo ufw disable.

Connection settings are set to the defaults in KDE system settings.

I opened Kinfocenter > Network Information > Network Interfaces on both machines to determine the IP Address of each. One machine reports: "eth0" and the other machine reports "eth0".

I opened Dolphin on the machine with the IP Address of and typed in the Location Bar: fish://bob@ and a red bar appears at the top stating: "Could not connect to host" (Note: I use bob as my user name on all of my local machines.)

I get similar results when trying to ftp or ssh.

I have also tried Places > Network > Network where I can see the remote machine's hard drive "elaterite3" listed, but when I double click on it nothing happens. It also show an earth icon that's labeled elaterite3 [f0:de:f1:6b:11:67]. I've tried double clicking that too, but nothing happens. I have also tried to right click on the two icons and select "open in Dolphin" and nothing happens.

Finally, I also have tried the following command in terminal "ssh -X bob@" and it returns: "ssh: connect to host port 22: Connection refused."

In all instances I have also replaced my user name, "bob," with the drive label "elaterite3" and have had no success.

I'm really stupid about all of this, so if you know what is going on, please provide your solution in a cookbook recipe format. For example, it took me about three hours to figured out what each machine's IP Address was. Everyone says, "Just type fish:// I had no clue what they meant by So please be specific.



Update: I discovered I need the package openssh-server which wasn't included in my distribution. I installed it and now can ssh into my other machine. However, following various instructions online I still can't copy a file or directory using scp from computer B to computer A.

Why is this so hard? I sure wish someone could suggest why I can't just use fish. Why is the connection refused?

But whatever, I ended up copying 50 gigs of files onto a 4gig thumb drive and finally got the files over to my main computer. :(
Registered Member
I'm getting the same error with fish:// , and I have the keys to the user login in a folder on my desktop, but I don't know how to give fish access to those keys.


Who is online

Registered users: bancha, Bing [Bot], Google [Bot], Sogou [Bot]