This forum has been archived. All content is frozen. Please use KDE Discuss instead.

KDE Connect won't see one device but works with others

Tags: kde connect kde connect kde connect
(comma "," separated)
Registered Member
**Please see the update at the bottom of the post for current software versions. I didn't want to change the text of my original post so I added the current versions that I've upgraded to since the post was created initially.

I have a strange problem. I have KDE Connect running on 5 computers and 3 mobile devices. Most all of them can see all of the other devices except one tablet is unable to see one of the desktops and that desktop can't see the tablet. They both see all of the other devices on the network without a problem.

I already know it's not a firewall issue (disabled) and I can ping the desktop from the tablet and the tablet from the desktop using both their IPs and hostnames.

My two phones and all other desktops can connect to this particular desktop with no issue.

I tried adding the IP and hostname of the desktop through "Add devices by IP" on the tablet which didn't work.

The tablet is able to see all of the other devices and is successfully paired with a few of them.

I'm running KDE Connect 1.17 on all the phones and tablets. The desktop in question is running Kubuntu 21.04 with Plasma 5.21.4

I'm not sure what to do, I've tried all I can think of and I've run out of ideas.

UPDATE: I installed the latest version that's on F-Droid on the device that won't see my desktop which at this point is 1.21.1. My desktop is also upgraded to Kubuntu 22.04 and running Plasma 5.24.7/KDE Framework 5.92.0. This still doesn't work and the only issue I have is that the specific desktop can't see this tablet. They both can see all other KDE connect enabled devices on my network. In case it's helpful, the tablet is an older Samsung SM-T230NU running Android 4.4.2 Kit-Kat.


Who is online

Registered users: bartoloni, Bing [Bot], Google [Bot], Yahoo [Bot]