This forum has been archived. All content is frozen. Please use KDE Discuss instead.

Cantor LaTeX output with Maxima backend not working

Tags: None
(comma "," separated)
Stefano Crocco
Registered Member
Hello to everyone,
I'm having an issue with the LaTeX output from the Maxima backend in Cantor. Enabling it doesn't display the expected output, but just a black rectangle with coloured pixels. It used to work at least until the beginning of last summer. Some months later, when I next used Cantor, it didn't work anymore. The same happened on my laptop; however, reinstalling the system (but keeping the home directory unchanged) fixed the issue. I tried uninstalling and reinstalling all the LaTeX related packages I could find (by the way, I'm on Gentoo) but it didn't help.

Running Cantor from a terminal, I get the following output which seems related to this issue:
Code: Select all
cantor - debug(from unknown:0): converting to eps:  "/usr/bin/dvips" -E -o "/tmp/cantor_46d57d31_bee1_4f43_a09d_736a5770f917.eps" "/tmp/cantor_46d57d31_bee1_4f43_a09d_736a5770f917.dvi"
cantor - debug(from unknown:0): remove temporary files for  "/tmp/cantor_tex-bccTME.tex"
cantor - debug(from unknown:0): rendered a result to  "/tmp/cantor_46d57d31_bee1_4f43_a09d_736a5770f917.eps"
cantor - debug(from unknown:0): setting result to a type  7  result
cantor - debug(from unknown:0): update Entry
cantor - debug(from unknown:0): rendering eps file:  QUrl("file:///tmp/cantor_46d57d31_bee1_4f43_a09d_736a5770f917.eps")
cantor - debug(from unknown:0): scale:  1.8
cantor - debug(from unknown:0): dimension:  84.6 x 21.6
**** Unable to open the initial device, quitting.
(libspectre) ghostscript reports: fatal internal error -100cantor - debug(from unknown:0): QUrl("internal:0a18327a_6506_4206_8bc1_213d75eab65d")

I tried opening the mentioned eps file with Okular and I got this error message:
Code: Select all
(libspectre) ghostscript reports: fatal internal error -100okular - warning(from unknown:0): Generated image does not match wanted size: [0x0] vs requested [1598x407]
okular - warning(from unknown:0): QImage::scaled: Image is a null image

However, I can open the file correctly using gs.

Does anyone have an idea about what could be causing this issue? I tried reporting a bug in the Gentoo bug tracker but they told me to report upstream. I think this is more a problem with my system than a bug in Cantor.

Thanks in advance



Who is online

Registered users: bartoloni, Bing [Bot], Google [Bot], Sogou [Bot], Yahoo [Bot]