This forum has been archived. All content is frozen. Please use KDE Discuss instead.

copy & paste stopped working

Tags: copy, paste, clipboard copy, paste, clipboard copy, paste, clipboard
(comma "," separated)
Registered Member

copy & paste stopped working

Tue Nov 03, 2020 6:01 pm
I have Debian 10 with KDE. Everything was working fine and suddenly today when I tried to copy a screenshot it didn't work. When I press the printscreen key, I get the popup showing the screenshot with the "copy to clipboard" button like normal, but when I try to paste it into GIMP or another image program I get:

"There is no image data in the clipboard to paste."

I tried to "restart" the clipboard by:

right-click on the system tray
uncheck clipboard
click apply (clipboard goes away)
check clipboard
click apply

This had no effect.

I am able to copy & paste text using ctrl-c/ctrl-v, but the text doesn't show up in the clipboard in the system tray. The images don't show up there either.

I discovered that in konsole if I highlight text and middle-click, it does NOT copy the highlighted text. So the clipboard is really messed up, but I can't figure out any way to reset it.

  • Just to verify, I am unable to copy either text or images to the clipboard. The "ignore images" option is unchecked, so that is not a factor. I'm not sure how ctrl-c/ctrl-v still works.
  • I tried restarting KDE (not the computer, just KDE) by entering:

Code: Select all
killall plasmashell
kstart plasmashell

and restarting KDE did NOT fix it.

I have:
Code: Select all
Debian GNU/Linux 10.6
KDE Plasma Version: 5.14.5
KDE Frameworks Version: 5.54.0
Qt Version: 5.11.3
Kernel Version: 4.19.0-10-amd64
OS Type: 64 -bit

I have this issue with the clipboard every 2 or 3 months. I can fix it by restarting the computer, but I would prefer to find a better way to fix it.

Is there some other way I can force the clipboard to restart or some way to fix this? Thanks.


Who is online

Registered users: Bing [Bot], Google [Bot], kesang, Yahoo [Bot]