This forum has been archived. All content is frozen. Please use KDE Discuss instead.

Plasma Freezing on SDDM Login After Update

Tags: None
(comma "," separated)
Registered Member
Hello everyone. Firstly, I apologise if i'm posting in the wrong section for this kind of issue. It is my first post in here.

I'm runnning Debian testing with KDE and never had any problems with it, until a recent update completely broke Plasma for me. After updating, Plasma no longer starts after logging in on SDDM, and after some time, the loading spinner stops being updated (it never disappears). I can still switch to other virtual terminals and open Konsole through Ctrl+Alt+T, and opening other GUI applications from there is possible (although they don't have the top bar). The desktop, however, is never loaded.

My computer has an Nvidia card but I run the Nouveau drivers for convenience and better support.

When I try to manually start the plasmashell process, the only error message displayed to me is:

Code: Select all
qt.qpa.xcb: could not connect to display
qt.qta.plugin: could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because not Qt platform plugin could be initialized. Reinstalling the application may fix this problem
Available platform plugins are: eglfs, linuxfb, minimaleg1, offscreen, vnc, wayland-eg1, wayland, wayland-composite-eg1, wayland-xcomposite-eg1, wayland-xcomposite-g1x, xcb

So far, i've tried rebooting, reinstalling xcb, reinsatlling all of libx11-* and none of this worked.

It would also be curious to mention that i've had exactly the same issue on another PC with vastly different hardware. The only way i've fixed it was nuking everything and downgrading to a fresh install of Debian stable.


Who is online

Registered users: bartoloni, Bing [Bot], Google [Bot], Sogou [Bot], Yahoo [Bot]