This forum has been archived. All content is frozen. Please use KDE Discuss instead.

Nexus 5X stuck at Google boot screen

Tags: cannot boot, nexus 5x, plasma mobile cannot boot, nexus 5x, plasma mobile cannot boot, nexus 5x, plasma mobile
(comma "," separated)
Registered Member
Ad5001 wrote:Having a fresh install of Plasma Mobile on a Nexus 5X, but after the process completes, the phones starts to boot, but gets stuck at the "Google" boot screen.

Thought I noticed some errors in the console, but they don't seem to be really fatal
Code: Select all
mount: mounting /dev/block/mmcblk0p40 on /cache failed: Device or resource busy
mount: mounting /dev/block/mmcblk0p45 on /data failed: Device or resource busy

adding android system image to installation ... __bionic_open_tzdata: couldn't find any tzdata when looking for GMT!

Easy fix: During the script execution after downloading and formatting, the devices is rebooted. This is when the script does a 'sleep' loop to stay paused until the device is ready. At this time: CTRL+Z to pause the script.

The device should be loaded in TWRP and displaying a message about mounting the system partition as read only, you want to do the swipe / accept modifications and then go into the mount menu, and uncheck all mountpoints.
There should be two checked, which match the two error messages.
Uncheck the two boxes, and then resume the script on your computer with the 'fg' command in terminal.

However in my case, this did not resolve the bootloop issue it only clears the errors.
Registered Member
Hello there :-)

I also had a problem like this. But for me it was the android device encryption. If you have this enabled, you defintily have to disable it at first.
Then do a factory reset, and finaly boot into fastboot and follow the step by step guide. Worked for me ...

Also i could not format cache and userdata with the fastboot version my repository has. ( Using KDE Neon and installed fastboot with apt-get )
To format cache and userdata i had to remove fastboot, and had to use the version fromthe archive located here
Registered Member
okay, its a little late now to answer, but maybe anyone can need my Infos.

I also run into trouble with the provided script. I got also the error-message, which says it could not mount cache / userdata. i reworked it by adding a umount command right before the mounting was proceed in the rootstock-touch-install script and the error-message dissapears.

The succesfull way to get everything flashed for me was to make my own script, download the needed images and the filesystem and worked it step by step out from there.

I managed to get the nexus 5x installed and it worked partly. I got a problem after doing a complete system update. After the update the phone stuck visualy on the google bootlogo. Via terminal from my usb-connectet host-pc, i was able to login to the phablet and do update/upgrade stuff, wifi connections, and some more. I think the problem is a grafics related problem with wayland components. Everything else i tried worked via terminal. Seems as if the updates had destroyed the wayland setup. But that is just a guess at the moment.


Who is online

Registered users: Bing [Bot], Google [Bot], kesang, Yahoo [Bot]