This forum has been archived. All content is frozen. Please use KDE Discuss instead.

Can't run `fastboot format` on Nexus 5X

Tags: None
(comma "," separated)
Registered Member
I'm trying to install Plasma Mobile on a Nexus 5X that currently has LineageOS 15 installed. (Instructions at I skipped step 1A, because my phone is already unlocked. At step 1B, the
Code: Select all
fastboot format
commands don't work. Here's what my terminal looks like:

Code: Select all
$ adb version
Android Debug Bridge version 1.0.39
Version 1:8.1.0+r23-7
Installed as /usr/lib/android-sdk/platform-tools/adb
$ fastboot devices
00d5d1f30f8e2ad3        fastboot
$ fastboot format cache
Couldn't parse erase-block-size '0x'.
Couldn't parse logical-block-size '0x'.
mke2fs 1.45.6 (20-Mar-2020)
/tmp/TemporaryFile-sjU8Ey: Unimplemented ext2 library function while setting up superblock
/usr/lib/android-sdk/platform-tools/mke2fs failed with status 1
mke2fs failed: 1
error: Cannot generate image for cache

Any ideas? Should I just skip this step?
Registered Member
I just reformatted my Nexus 5X because it crashed while updating around 800 Mb and got stuck at boot afterwards.

While I didn't run into named problem before, after upgrading to the latest 20.04 rebase of KDE Neon, my system showed me the same error that you got.

I solved it by booting into (TWRP-)recovery and formatting my device from there.

Afterwards I just continued with the script. Please note that this advice helped me a lot!


Who is online

Registered users: Bing [Bot], Google [Bot], kesang, Yahoo [Bot]