This forum has been archived. All content is frozen. Please use KDE Discuss instead.

Failed packages building Plasma

Tags: None
(comma "," separated)
User avatar
Registered Member

Failed packages building Plasma

Thu Mar 05, 2020 12:16 am
Hello! I love KDE and am hoping to contribute, I have hit a few snags. (running Manjaro)

I have been following the getting started guide:

I had a few failures but managed to resolve them myself until now.

I successfully built and ran Dolphin as a test. Now I am trying to build Plasma per the example with:

Code: Select all
kdesrc-build plasma-desktop plasma-workspace plasma-framework plasma-nm plasma-pa plasma-thunderbolt plasma-vault plasma-workspace-wallpapers kdeplasma-addons kwin systemsettings kscreen breeze discover kinfocenter --include-dependencies

I haven't been able to resolve the remaining failures:

Code: Select all
libksysguard - ~/kde/src/log/2020-03-04-03/libksysguard/build.log
plasma-workspace - ~/kde/src/log/2020-03-04-03/plasma-workspace/build.log
ksysguard - ~/kde/src/log/2020-03-04-03/ksysguard/build.log
powerdevil - ~/kde/src/log/2020-03-04-03/powerdevil/cmake.log
systemsettings - ~/kde/src/log/2020-03-04-03/systemsettings/cmake.log
discover - ~/kde/src/log/2020-03-04-03/discover/build.log
plasma-desktop - ~/kde/src/log/2020-03-04-03/plasma-desktop/cmake.log

I did try:
Code: Select all
kdesrc-build [failing module] --refresh-build

as well as going through ... pendencies again to make sure I have everything called for on Manjaro.

An example of my troubleshooting, libksysguard (build.log) - I don't see anything terribly descriptive, though I am not sure what I am looking for. The only thing that stands out is "Error 2". So I checked the build directory:


Which shows one promising item:

Code: Select all
/home/merritt/kde/build/libksysguard/CMakeFiles/CheckIncludeFiles/HAVE_SYS_ENDIAN_H.c:2:10: fatal error: sys/endian.h: No such file or directory

I have no idea what to do about this error, and searching for sys/endian.h only seems to bring information on Android, OSX, code snippets, etc.

I am not a developer so this is all a bit out of my scope, I am sure I did something funny (and probably simple). I'd very much like to get this figured out and try my hand at contributing though :)

Terminal output:


Registered Member

Re: Failed packages building Plasma

Fri Mar 06, 2020 8:56 pm
kdesrc-build does try to be helpful when things go wrong by pointing out which log files you should look at to see what's going on and will generally create an error.log link to the log file containing the error.
Now unless you are making changes to the source code, most of the build failures should only be due to missing required dev packages (named after the original library package, but with a '-dev' or '-devel' suffix) which provide the header files (files with a .h extension) needed as part of building the project. As such, I'd recommend also examining the cmake.log file to make sure it found all of the required (and optional) packages as the names in that log should more closely resemble the names of the dev packages you'll need to install.

Now in the case of this particular message when building libksysguard, taking a look at your logs and such, it looks like it may be just assuming the package to already be there for some reason and not checking for it explicitly in cmake.log. Checking on my system (ubuntu 18.04), the sys/endian.h file is provided by the libbsd-dev package.

tl;dr: install the libbsd-dev package and try again ;)

airdrik, proud to be a member of KDE forums since 2008-Dec.
User avatar
Registered Member

Re: Failed packages building Plasma

Sat Mar 07, 2020 1:08 am
Thanks getting back to me, appreciate your time! :)

I searched for libbsd on my system, there doesn't appear to be a -dev package available on Manjaro.

I already have the libbsd package installed. For the sake of thoroughness I tried building the lib32-libbsd AUR package and building libksysguard again, however it didn't make any difference.

Per your suggestion I did a search for cmake.log files;

libksysguard doesn't have anything that jumps out at me

powerdevil has an error regarding LibKWorkSpace:

Code: Select all
CMake Error at CMakeLists.txt:48 (find_package):
  Could not find a configuration file for package "LibKWorkspace" that is
  compatible with requested version "5.18.80".

  The following configuration files were considered but not accepted:

    /usr/lib64/cmake/LibKWorkspace/LibKWorkspaceConfig.cmake, version: 5.17.5
    /usr/lib/cmake/LibKWorkspace/LibKWorkspaceConfig.cmake, version: 5.17.5
    /lib64/cmake/LibKWorkspace/LibKWorkspaceConfig.cmake, version: 5.17.5
    /lib/cmake/LibKWorkspace/LibKWorkspaceConfig.cmake, version: 5.17.5

with that same error present in systemsettings & plasma-desktop. I presume this is because the Manjaro version of Plasma is still 5.17.5, but it is requiring the newest.

It looks like libkworkspace is a part of plasma-workspace which had also failed to build, so I looked closer at that.

plasma-workspace failed with a generic "Error 2" and contains no cmake.log, so I have no idea how to proceed there.

Thanks for your patience, I feel like I must be missing something obvious! :)


Who is online

Registered users: bartoloni, Bing [Bot], Google [Bot], Yahoo [Bot]