This forum has been archived. All content is frozen. Please use KDE Discuss instead.

Dual display not working after updating to Neon 5.26

Tags: None
(comma "," separated)
Registered Member
Just updated to 5.26, and my dual display is no longer working.
I have a Radeon RX580 with two HDMI monitors connected. They worked fine before upgrade.
I have signal on both monitors, but both display the same screen.

in control panel, it only displays one of the monitors, and xrander also only lists one:
Code: Select all
xrandr --listmonitors
xrandr: Failed to get size of gamma for output default
Monitors: 1
 0: +*default 1920/508x1080/286+0+0  default

lshw reports:
Code: Select all
lshw -c video
       description: VGA compatible controller
       product: Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:0e:00.0
       logical name: /dev/fb0
       version: e7
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom fb
       configuration: depth=32 driver=amdgpu latency=0 resolution=1920,1080
       resources: irq:123 memory:e0000000-efffffff memory:f0000000-f01fffff ioport:f000(size=256) memory:fce00000-fce3ffff memory:c0000-dffff

I tried the old and tested boot flag amdgpu.dc=0, but that doesn't make the second monitor appear.

Switch from Plasma X11 to Plasma Wayland on the login screen, and second monitor is now recognized.
Registered Member
I have this problem too, except mine stopped working in the middle of a work session. This is a deal breaker if it doesn't get fixed.

Update: After much web searching and no answer, I went to Display Configuration and opened the drop down menu for devices and, lo and behold, the ASUS monitor was there but showed it was disabled! Just had to enable and designated as primary. Problem solved. Strange. Very strange.


Who is online

Registered users: bartoloni, Bing [Bot], Google [Bot], Sogou [Bot], Yahoo [Bot]