This forum has been archived. All content is frozen. Please use KDE Discuss instead.

Problems running kdepim4 on OS X Yosemite

Tags: None
(comma "," separated)
Registered Member
Operating system is OSX 10.10.3. I installed kdepim through MacPorts.

Short story, I'm getting a certificate error when I setup a google calendar account on korganizer.

Long sorry...

I ran kbuildsycoca4 and started the LaunchAgent after the install. Then when I started kmail and setup an imap account and started getting an error about an invalid certificate (I have the same account setup in Linux and don't remember ever getting this error, if it did it got fixed the first time I accepted the cert). Everytime this popped up I clicked continue and to accept the certificate Forever. But the popup keep coming back every 5 minutes. I kept accepting it until it started crashing. Then I rebooted and kmail would not work anymore. I figured it would work only if I started akonadi before running kontact (or kmail). I think this was related to the environment variables used by kmail (it would launch akonadi_control but akonadi_control would never exit so kmail waits forever for akonadi. I found that akonadi_control hangs if /opt/local/bin is not on the search path). I managed to fix this by running this script from a LaunchAgent:

Code: Select all
export PATH=/opt/local/bin:$PATH
akonadictl start

After that I deleted ~/.config/akonadi and setup my account again and this time it worked flawlessly without asking me to accept the cert. Now I'm trying to sync with my google calendar. As soon as I add the calendar resource I start getting the certificate prompt again. I accept it but it keeps prompting until it crashes. I tried deleting the google resource file from ~/.config/akonadi, rebooting it and adding it again but it keeps prompting until it starts crashing.


Who is online

Registered users: bartoloni, Bing [Bot], Google [Bot], Sogou [Bot], Yahoo [Bot]