![]() Registered Member ![]()
|
Hi,
I'm trying to add 'tags' functionality to KMyMoney and I've some questions to the developers. I'm creating a new subclass of KMyMoneyMVCCombo: MyMoneyTagCombo, in a similar way as the class KMyMoneyPayeeCombo I created also a new subclass of MyMoneyObject: MyMoneyTag. The MyMoneyTag have a valid_from and valid_to date fields, they are optional but if filled in the transaction editor widget will appear only tags that have the date of the transaction between valid_from and valid_to. At this time the transaction date is filled after the filling of Category field, and I thought to put the Tag field just after the Category one. Do you think that the date field can be put just after the Payee field or there is a good reason to put it where it's now? I think that allowing tags to be hierarchical is good idea (just a little example: the user may want to put all tags like: Paris-2010, Rome-2011 under a parent tag named Travel) do you think that it can be made by following the KMyMoneyCategory class (i.e. by making a subclass of KMyMoneyCombo) or should I subclass KMyMoneyMVCCombo as I'm doing now? |
![]() Registered Member ![]()
|
I think it should be before or after the Notes field, and using the KMyMoneyCombo to make it hierarchical makes sense.
Please, if possible, use the kmymoney-devel mailing list for stuff like this. And when done for review, please use git.reviewboard.kde.org to submit the patch.
Hei Ku, proud to be a member of the KMyMoney Development Team since January-2008
|
![]() KDE Developer ![]()
|
Wouldn't visible_from and visible_until be better names for the date range since the tags are valid beyond these dates, right?
Regarding the placement of the widget in the transaction editor: The location on screen is not necessarily tied to the position of the widget in the tab order. There is an option to override the tab order by the user (there is no user interface to do so, but still it exists) and thus simply changing the location of the widgets on screen does not change the tab-order. Once you have the feature ready, we can think about a default position of the tag-widget in the tab-order. I am not sure about sub-classing those objects you refer to. cristian.onet needs to take a look at those since he last modifed them (= ported them to KDE4). p.s. Subscribing to the developer mailing list might be a better idea. Check https://mail.kde.org/mailman/listinfo/kmymoney-devel
ipwizard, proud to be a member of the KMyMoney forum since its beginning.
![]() openSuSE Leap 15.4 64bit, KF5 |
![]() Registered Member ![]()
|
Thanks for the suggestions, I'll subscribe to the kmymoney-devel.
About the right class to subscribe, in the comment to KMyMoneyMVCCombo Cristian Onet writes:
I'll ask him about this. |
Registered users: bartoloni, Bing [Bot], Evergrowing, Google [Bot], ourcraft