Reply to topic

Zoom Out?

bgravelston
Registered Member
Posts
4
Karma
0
OS

Zoom Out?

Mon Sep 30, 2013 2:19 am
I accidentally used the default [Ctrl] + [+] keyboard shortcut, causing the desktop to zoom into the area around the pointer. However, the system does not appear to recognize the default or customized "Zoom out" shortcuts, making it impossible to return the desktop to its normal size. The login screen looks just fine, but logging into my user account reveals that closing the previous session did not eliminate the problem. Are there any settings or files that can be changed to return the desktop to the correct size?
User avatar scummos
Global Moderator
Posts
1116
Karma
7
OS

Re: Zoom Out?

Mon Sep 30, 2013 10:53 am
Just adding that I had this problem too and it was quite horrible since I had to delete the config file to get back. It's a real "break the desktop" button ;)
I didn't report it back then because I assumed I was just being stupid, but reading this it seems to be a real problem.

You should be able to undo it until someone comes up with a better solution by disabling desktop effects with shift+alt+F12.

Greetings,
Sven


I'm working on the KDevelop IDE.
User avatar google01103
Manager
Posts
6668
Karma
25

  Topic is solved

Mon Sep 30, 2013 11:05 am
if you rename ~/.kde/share/config/kwinrc OR ~/.kde4/share/config/kwinrc depending on version of Linux
Code: Select all
mv $KDEHOME/share/config/kwinrc $KDEHOME/share/config/kwinrc-old

and then run
Code: Select all
kwin --replace &

your Kwin setting should be reverted to the defaults

alternatively you could edit that file and then run kwin --replace


OpenSuse Leap 42.1 x64, Plasma 5.x

mgraesslin
KDE Developer
Posts
572
Karma
7
OS

Re: Zoom Out?

Mon Sep 30, 2013 11:08 am
For Sven I can explain the issue. You are using a German keyboard layout? If yes: the default zoom out shortcut cannot be pressed on a German layout :-(
User avatar scummos
Global Moderator
Posts
1116
Karma
7
OS

Re: Zoom Out?

Mon Sep 30, 2013 11:43 am
Yes, I use a German layout -- haha, that explains it then I guess ;)

But even if it were not for this problem, from a usability perspective I'd say there should be a more obvious way to get out of the zoom mode... especially if it persists after restarting the session.


I'm working on the KDevelop IDE.
mgraesslin
KDE Developer
Posts
572
Karma
7
OS

Re: Zoom Out?

Mon Sep 30, 2013 2:41 pm
scummos wrote:But even if it were not for this problem, from a usability perspective I'd say there should be a more obvious way to get out of the zoom mode... especially if it persists after restarting the session.

IIRC we changed it to be persistant as users said they need it from an accessibility point of view.
bgravelston
Registered Member
Posts
4
Karma
0
OS

Re:

Mon Sep 30, 2013 8:08 pm
google01103 wrote:if you rename ~/.kde/share/config/kwinrc OR ~/.kde4/share/config/kwinrc depending on version of Linux
Code: Select all
mv $KDEHOME/share/config/kwinrc $KDEHOME/share/config/kwinrc-old

and then run
Code: Select all
kwin --replace &

your Kwin setting should be reverted to the defaults

alternatively you could edit that file and then run kwin --replace


Thank you, this solved the problem. Now I'll reassign/disable that kb shortcut!

I agree with Sven that there should be a more obvious way to zoom out. I'm using the US English keyboard layout and the zoom out shortcuts don't work on that, either. Maybe add a graphical control for this somewhere in System Settings if there isn't one already.
doki
Registered Member
Posts
1
Karma
0

Re: Zoom Out?

Tue Mar 25, 2014 11:38 am
Instead of delete the file $KDEHOME/share/config/kwinrc i edit it and set the value for InitialZoom to 1

Code: Select all
[Effect-Zoom]
InitialZoom=1



Then i pressed shift+alt+F12 two times in order to disable/enable the desktop effects.
ericjs
Registered Member
Posts
10
Karma
0

Re: Zoom Out?

Fri Jul 24, 2015 5:57 pm
Thanks doki for that solution! I came here after accidentally activating this zoom. I use ctrl + and ctrl - all the time to change the text size in my browser, and this is the first time in the 2 years or so I've been using KDE that I somehow accidentally triggered this desktop zoom instead. But I think I'm missing something about how the Plasma shortcuts work. The system settings seem to show both Ctrl + to zoom in and Ctrl - to zoom out, but I can't for the life of me get these to work now. I've even tried minimizing all windows to click on the desktop. Ctrl + now seems to bring up the...whatdyacallit...the little bar at the top that I normally use alt-F2 for.

Is there something about how one shifts focus in Plasma that I'm somehow entirely missing? (Every now and then using the scroll wheel on a window, I'll activate the switch desktop or activity, whichever it is, which also drives me nuts.)
jessej
Registered Member
Posts
10
Karma
0
OS

Re: Zoom Out?

Thu Dec 17, 2015 9:50 am
I met with somewhat similar issues -> someone unknowingly pushed zoom shortcut. This thread helped to find easy solution so here it is for posterity:
On KDE Platform Version 4.14.9 it seems that desktop zoom is done with Kwin/Desktop effects. So it does not work when Desktop effects are disabled (Global shortcut Alt+Shift+F12 to togle on and off). In System Settings -> Global Shortcuts I have zooming-shorcuts only in Kwin section. Defaults seems to be Meta+= and Meta+- (Meta is Windows button, next to left Ctrl). In my keyboard layout in practice its Meta+Shift+= and Meta+-. Shift is needed to get secondary = character of a button and minus sign from numpad doesnt work, only dash next to Shift-button. I cannot say if these have changed recently.
Wenzel
Registered Member
Posts
26
Karma
0
OS

Re: Zoom Out?

Sun Nov 06, 2016 11:16 am
Hi

i just had the same issue with
Code: Select all
 kwin 5.7.5
.
Impossible to zoom out, i had to disable the desktop effects.

i tried to change the shortcut for zooming out, but it didn't work.
This is a bug that should be reported.

Thanks.
semjonw
Registered Member
Posts
1
Karma
0

Re: Zoom Out?

Wed Jul 05, 2017 7:37 am
I also accidently hit the shortcut for zooming in. I also was using a german keyboard and the shortcut didnt work like mgraesslin mentioned.

So I disabled Desktop Effects using Shift+Alt+F12, changed the keyboard layout to English-US and used the common shortcut ( https://docs.kde.org/trunk5/en/applicat ... s/kbd.html ) to zoom out again.


Greetings,
Semjon

 
Reply to topic

Bookmarks



Who is online

Registered users: avidscavenger, Baidu [Spider], Bing [Bot], Exabot [Bot], Google [Bot], Ranko Kohime, scowler1, Sogou [Bot], Yahoo [Bot]