Reply to topic

How to change speed of Fade desktop effect

farukdgn
Registered Member
Posts
6
Karma
0
Hi. I'm using Kubuntu 16.10 with KDE Plasma 5.6.

I'm using Fade (I'm not sure about the English name) effect in Desktop Effects. However I'm not happy with its current speed so I want to change it but I can't find how to do it. I don't want the speed change affect any other effect, just Fade.

Is there any way to change this? I want to make things appear quickly so I want to make fading in faster.

Thanks.
pataphysicianer
Registered Member
Posts
6
Karma
0
You will have to change the config file for the fade effect if you want to change the speed separate from the animation speed setting, in System Settings > Displays and Monitor > Compositor

The config file is probably in your
/usr/share/kwin/effects/kwin4_effect_fade/content/config/main.xml
this file has fade in and fade out times

Instead of editing this file directly, make the corresponding directories under
~/.local/share/kwin/
and then copy the main.xml from the directory above in /usr to the corresponding directory in .local, and then edit that file.

you could copy the whole contents of the kwin4_effects_fade directory as well, but this way when an kde update comes your only overriding the config main.xml and not overriding any new changes to the javascript code.

file location might vary by distro
pataphysicianer
Registered Member
Posts
6
Karma
0
forgot to mention you also will need to restart kwin for the change to take place.

you can use krunner (ALT+F2) to run

kwin_x11 --replace

if your using x11

or kwin_wayland --replace

if your using wayland
farukdgn
Registered Member
Posts
6
Karma
0
pataphysicianer wrote:You will have to change the config file for the fade effect if you want to change the speed separate from the animation speed setting, in System Settings > Displays and Monitor > Compositor

The config file is probably in your
/usr/share/kwin/effects/kwin4_effect_fade/content/config/main.xml
this file has fade in and fade out times

Instead of editing this file directly, make the corresponding directories under
~/.local/share/kwin/
and then copy the main.xml from the directory above in /usr to the corresponding directory in .local, and then edit that file.

you could copy the whole contents of the kwin4_effects_fade directory as well, but this way when an kde update comes your only overriding the config main.xml and not overriding any new changes to the javascript code.

file location might vary by distro


Thank you for the answer. But I have a problem. I've copied main.xml into ~/.local/share/kwin/effects/kwin4_effect_fade/content/config/ and changed the contents there but nothing changed. When I edited the file directly at /usr/share/kwin/effects/kwin4_effect_fade/content/config/, it worked.
pataphysicianer
Registered Member
Posts
6
Karma
0
farukdgn wrote:
Thank you for the answer. But I have a problem. I've copied main.xml into ~/.local/share/kwin/effects/kwin4_effect_fade/content/config/ and changed the contents there but nothing changed. When I edited the file directly at /usr/share/kwin/effects/kwin4_effect_fade/content/config/, it worked.


The directory is contents not content, just add an s to that particular directory name. Sorry, I should have written out the command to copy directory structure without files, as it's very easy to get them wrong when doing it manually, and then still look right, I've done it a million times :)
farukdgn
Registered Member
Posts
6
Karma
0
pataphysicianer wrote:
farukdgn wrote:
Thank you for the answer. But I have a problem. I've copied main.xml into ~/.local/share/kwin/effects/kwin4_effect_fade/content/config/ and changed the contents there but nothing changed. When I edited the file directly at /usr/share/kwin/effects/kwin4_effect_fade/content/config/, it worked.


The directory is contents not content, just add an s to that particular directory name. Sorry, I should have written out the command to copy directory structure without files, as it's very easy to get them wrong when doing it manually, and then still look right, I've done it a million times :)


Hehe, yes it was the mistake. Thank you!
farukdgn
Registered Member
Posts
6
Karma
0
Hello again,

This setting stopped working for right click menus after updating to Kubuntu 19.04. However, it works for window close animations. I have checked the contents of files but it seems OK. Do you have any idea why?

Thanks

 
Reply to topic

Bookmarks



Who is online

Registered users: Bing [Bot], bovender, gfielding, Google [Bot], hiteshshah, lucianosalomoni, Majestic-12 [Bot], Sentinel, TheBeheader, Yahoo [Bot]