Topic locked

Keyboard stops working

jgruber
Registered Member
Posts
4
Karma
0

Keyboard stops working

Mon Jul 23, 2018 3:58 pm
My keyboard stops working in the middle of a Kwin session for all my KDE applications but continues to work in gtk, console, other X11 applications (xev Keyboard* events firing just fine). Anyone explain how Xorg inputs get re-routed in kwin in a way that would consume all the keyboard events?

I am using Plasma 5 on Xorg, not Wayland. The only way to get the keyboard back is to reboot. Restarting kwin (kwin --restart) doesn't help. I've tried multiple keyboards, same results. Any ideas, suggestions?
jgruber
Registered Member
Posts
4
Karma
0

Re: Keyboard stops working  Topic is solved

Mon Jul 23, 2018 5:09 pm
Sorry to self-post... but I found a solution through the Arch forums... It's an ibus issue. :(

Performing the following fixes my issue:

Code: Select all
ibus-daemon --xim -d


Also have to make sure it is running on my session startup:

Code: Select all
ibus-daemon -d -n --desktop=KDE


There are issues already entered to get this fixed.
overman
Registered Member
Posts
1
Karma
0

Re: Keyboard stops working

Thu Apr 09, 2020 10:44 pm
2020 update, that just worked for me now.
sirvaude
Registered Member
Posts
2
Karma
0

Re: Keyboard stops working

Sun Nov 22, 2020 11:19 pm
Same problem, same solution.

Debian Testing
KDE 5.74.0 / Plasma 5.19.5
deano019s
Registered Member
Posts
1
Karma
0

Re: Keyboard stops working

Wed Jun 23, 2021 12:46 am
Thank you! Same issue here, this fixed it.
Debian Testing/11
Plasma 5.22.1

 
Topic locked

Bookmarks



Who is online

Registered users: ajenn, Bing [Bot], dacorsa, dzon, Google [Bot], Mamarok, reuze, Sogou [Bot], spondex, Yahoo [Bot]