Reply to topic

[SOLVED] Problem with kwinrc

Travelskid
Registered Member
Posts
4
Karma
0

[SOLVED] Problem with kwinrc

Wed Apr 03, 2019 9:29 pm
Hi everyone, i've a little problem with kwinrc config file. I want remove title bar in maximized windows so in
Code: Select all
~/.config/kwinrc
i changed
Code: Select all
BorderlessMaximizedWindows=false
from false to true, and it works.

But when i reboot the windows back to default state because the "BorderlessMaximizedWindows" option return to false value itself.
I don't understand why! Someone can help me with this problem?


My pc:
Code: Select all
     
                  .o+`                 
                 `ooo/                 OS: Arch Linux
                `+oooo:                Kernel: x86_64 Linux 5.0.5-arch1-1-ARCH
               `+oooooo:               Uptime: 3h 16m
               -+oooooo+:              Packages: 919
             `/:-:++oooo+:             Shell: bash 5.0.2
            `/++++/+++++++:            Resolution: 1920x1080
           `/++++++++++++++:           DE: KDE 5.56.0 / Plasma 5.15.4
          `/+++ooooooooooooo/`         WM: KWin
         ./ooosssso++osssssso+`        CPU: Intel Core i7-8750H @ 12x 4.1GHz [27.8°C]
        .oossssso-````/ossssss+`       GPU: GeForce GTX 1050 Ti
       -osssssso.      :ssssssso.      RAM: 1486MiB / 15927MiB
      :osssssss/        osssso+++.   
     /ossssssss/        +ssssooo/-   
   `/ossssso+/:-        -:/+osssso+- 
  `+sso+:-`                 `.-/+oso:
 `++:.                           `-/+/
 .`                                 `/

Last edited by Travelskid on Mon Apr 08, 2019 5:07 pm, edited 1 time in total.
airdrik
Registered Member
Posts
1588
Karma
3
OS

Re: Problem with kwinrc

Fri Apr 05, 2019 9:57 pm
You might try changing that while logged out of KDE to ensure that kwin isn't trying to remember the setting and overwriting it on you.
If that doesn't work, you can try this script on the kde store (you can install it through System Settings -> Window Management -> KWin Scripts -> Get New Scripts...)


airdrik, proud to be a member of KDE forums since 2008-Dec.
Travelskid
Registered Member
Posts
4
Karma
0

Re: Problem with kwinrc

Mon Apr 08, 2019 4:34 pm
airdrik wrote:You might try changing that while logged out of KDE to ensure that kwin isn't trying to remember the setting and overwriting it on you.
If that doesn't work, you can try this script on the kde store (you can install it through System Settings -> Window Management -> KWin Scripts -> Get New Scripts...)


Nothing to do. I've tried to change the value before login (changing the value with nano in a virtual console ctrl+alt+fX) but after login back to false. I also try changing other values and it does, so the problem seems to be only in "BorderlessMaximizedWindows".
Script don't works: from "Get New Scripts..." don't install nothing; i've manually installed it (download from git and copy in /home/$USER/.local/share/kwin/scripts/) but don't work.

With my old PC (last upgrade was about 2 weeks ago) that more or less had same OS, software and configuration, i din't had this problem. But for now seems a kwin bug, do you think is better open an issue on https://bugs.kde.org/?
Travelskid
Registered Member
Posts
4
Karma
0

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], bartoloni, Bing [Bot], duns, Exabot [Bot], Google [Bot], smrtsmith, Sogou [Bot], tburke, Yahoo [Bot]