Reply to topic

[SOLVED] KWin random crashes.

User avatar Moult
Global Moderator
Posts
663
Karma
2
OS

[SOLVED] KWin random crashes.

Fri Feb 20, 2009 5:37 pm
Recently (maybe after upgrading to xorg-server 1.5.3-r1 [though now I am on r2]) I have noticed that certain actions will cause KWin to crash and therefore cause X to restart. This is very annoying. Such actions can be like right click -> appearance settings then selecting a drop down menu, or right clicking the KMix icon (this one works sometimes), or really random dropdowns and right clicks cause this. Sometimes it happens always at one place (like appearance settings dropdowns) and sometimes it's a bit random whether it works or not.

I've tried restarting plasma, restarting X, restarting my computer, removing the .kde4 directory, changing plasma theme, changing window border style, changing widget style, reinstalling the whole of KDE 4.2 ... nothing worked.

I'm stumped.

Help? Any ideas how to debug this?

(Running NVIDIA GeForce 9100M G with nvidia-driver 180.27, KDE 4.2.0, Gentoo Linux)

Last edited by Moult on Fri Feb 20, 2009 5:38 pm, edited 1 time in total.


Moult, proud to be a member of KDE forums since 2008-Oct.
thinkMoult - source for tech, art, and animation: hilarity and interest ensured!
WIPUP.org - a unique system to share, critique and track your works-in-progress projects.
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS

[SOLVED] KWin random crashes.

Fri Feb 20, 2009 9:14 pm
Apparently disabling "Present Windows" will prevent this from occurring.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar Moult
Global Moderator
Posts
663
Karma
2
OS

[SOLVED] KWin random crashes.

Fri Feb 20, 2009 11:45 pm
Thank you!

After disabiling the effect, I tried going to appearance settings and clicking a drop down once more. Again it crashed, but when starting up again, now it all seems to work fine.

However, like the guy in the other thread, it happens randomly so I'm unsure as to whether or not it's been really fixed. But I'll mark it solved and only if it starts to recurr then I will bump this thread.

Thanks again!


Moult, proud to be a member of KDE forums since 2008-Oct.
thinkMoult - source for tech, art, and animation: hilarity and interest ensured!
WIPUP.org - a unique system to share, critique and track your works-in-progress projects.
User avatar Moult
Global Moderator
Posts
663
Karma
2
OS

[SOLVED] KWin random crashes.

Sat Feb 21, 2009 9:19 am
Ok. I have unsolved this thread because that is only a temporary fix. Basically for me, once I set a no present windows effects, it will crash, then only on the next X startup it will work. However, it will only work ONCE. After you close that appearance settings window and made your changes, when you open it again KWin will crash just like before. Or if you restart X again, KWin will continue its crashes.

Another place I found this crash was when adding a new activity, zooming into that activity, then trying to drag/drop a widget from the add widget dialog. Can anybody confirm this?

I don't think it's a driver problem, as this popped up without any driver upgrades.


Moult, proud to be a member of KDE forums since 2008-Oct.
thinkMoult - source for tech, art, and animation: hilarity and interest ensured!
WIPUP.org - a unique system to share, critique and track your works-in-progress projects.
User avatar Zarin
KDE Developer
Posts
345
Karma
8
OS

[SOLVED] KWin random crashes.

Sat Feb 21, 2009 9:40 am
Backtraces please.
User avatar Moult
Global Moderator
Posts
663
Karma
2
OS

[SOLVED] KWin random crashes.

Sun Feb 22, 2009 2:05 am
Well, turns out somebody on IRC also had the same issue I had, and the fix is to disable the BackingStore option in xorg.conf. Now it works fine :)

Solved. (for real now I think)


Moult, proud to be a member of KDE forums since 2008-Oct.
thinkMoult - source for tech, art, and animation: hilarity and interest ensured!
WIPUP.org - a unique system to share, critique and track your works-in-progress projects.
User avatar Johnny Jupiter
Registered Member
Posts
4
Karma
0
OS

RE: [SOLVED] KWin random crashes.

Fri Mar 06, 2009 11:58 am
Moult wrote:Well, turns out somebody on IRC also had the same issue I had, and the fix is to disable the BackingStore option in xorg.conf. Now it works fine :)

Solved. (for real now I think)



i had the same problem and disabling option backingstore solved this issue.
nvidia 180.29

thanks
algol.tr
Registered Member
Posts
9
Karma
0

RE: [SOLVED] KWin random crashes.

Fri Mar 06, 2009 9:33 pm
what I do insert in my xorg.conf?
please help kwin crash very often.

ps:sorry for my english


algol.tr, proud to be a member of KDE forums since 2008-Oct.
User avatar Moult
Global Moderator
Posts
663
Karma
2
OS

RE: [SOLVED] KWin random crashes.

Sat Mar 07, 2009 2:36 am
algol.tr, it's actually what do you _remove_ from your xorg.conf. Search for any lines in the Section "Device" sections which have the word BackingStore in it. Remove any lines with the word BackingStore in it.


Moult, proud to be a member of KDE forums since 2008-Oct.
thinkMoult - source for tech, art, and animation: hilarity and interest ensured!
WIPUP.org - a unique system to share, critique and track your works-in-progress projects.
algol.tr
Registered Member
Posts
9
Karma
0

RE: [SOLVED] KWin random crashes.

Sat Mar 07, 2009 9:58 am
I had not any backingstore option,
so I added: Option "backingstore" "false"
but nothing.
I must wait a rebuild of my kde pakage...


algol.tr, proud to be a member of KDE forums since 2008-Oct.

 
Reply to topic

Bookmarks



Who is online

Registered users: acrux, Baidu [Spider], Bing [Bot], dimzev, Google [Bot], Majestic-12 [Bot], peje, Sogou [Bot], YaCy [Bot], Yahoo [Bot]