Reply to topic

Disabling kwin composite efects? How?

User avatar Gediminas
Registered Member
Posts
3
Karma
0
Hello everyone, I apologize for my bad English,

I have a nvidia geforce 7600 graphics card, the composite effects are nice, but useless to me.
I tried disabling them in systemsettings, however they are visually disabled, glxgears still give me ~5 fps.

I sometimes play some games that require glx, so is there a better way than using
Code: Select all
icewm-lite --replace

:undecided:

Using Kubuntu 8.10 (alpha-beta or something (updating now))
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
Open the file ~/.kde4/share/config/kwinrc

You will find ( if it is enabled ) a [compositing] section
In it you should find a line "Enabled = True"
Change it to "Enabled = False"

If that file doesn't exist try this one
~/.kde/share/config/kwinrc

Then log out then back in.

This will disable kwin's compositing so you shouldn't need to remove it.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar JontheEchinda
KDE Developer
Posts
309
Karma
4
OS
You can also apt-get install plasmoid-toggle-compositing. It's a really nifty plasmoid that allows you to easily toggle compositing on and off with one mouse click.


JontheEchinda, proud to be a member of the Kubuntu team since July 2008.
Image
Image
User avatar Jucato
Registered Member
Posts
67
Karma
1
OS
This command will disable compositing in the kwinrc config file:

Code: Select all
kwriteconfig --file kwinrc --group Compositing --key Enabled false


Then restart kwin (in Alt+F2) with:

Code: Select all
kwin --replace


To get compositing back, just substitute false with true and restart kwin again.

Or use that plasmoid Jonathan mentioned (though I haven't seen it yet). :D


Jucato, proud to be a member of KDE forums since 2008-Oct.
User avatar infyrno
Registered Member
Posts
6
Karma
0
Gediminas wrote:Hello everyone, I apologize for my bad English,

I have a nvidia geforce 7600 graphics card, the composite effects are nice, but useless to me.
I tried disabling them in systemsettings, however they are visually disabled, glxgears still give me ~5 fps.

I sometimes play some games that require glx, so is there a better way than using
Code: Select all
icewm-lite --replace

:undecided:

Using Kubuntu 8.10 (alpha-beta or something (updating now))


You can also click on the "K" button go to computer -> system settings -> Desktop -> Desktop Effecs, check off Enable desktop effects.


infyrno, proud to be a member of KDE forums since 2008-Oct.
User avatar Gediminas
Registered Member
Posts
3
Karma
0
Thank you for your advices, unfortunately the effects get turned off, but glxgears is still on 3 fps (compared with 6k fps when switched to icewm-lite)

Could this be a bug in the driver or kwin itself?

BTW, same frame-drop using compiz.
User avatar Cypher
Registered Member
Posts
28
Karma
0
OS
Another, simpler solution : Shift + Alt + F12 to toggle compositing ON/OFF (works on Neon KDE Nightly)


Cypher, proud to be a member of KDE forums since 2008-Oct.
JackieBrown
Registered Member
Posts
21
Karma
0
Cypher wrote:Another, simpler solution : Shift + Alt + F12 to toggle compositing ON/OFF (works on Neon KDE Nightly)


You can change that to whatever you want in system settings --> keyboard and mouse --> and global keyboard shortcuts


Debian GNU/Linux Sid

KDE trunk
michael4910
Alumni
Posts
100
Karma
0
OS
argh, I just got this message:
"Compositing was too slow and has been suspended. If this was only a temporary problem, you can resume using the '%1' shortcut"
Unfortunately the message didn't stay long enough to read the whole text and google only found the i18n text without the actual shortcut. So I hope after the next time that Google will index this forum other people with the same "problem" will find this post and the the two posts above this one... ,-)


michael4910, proud to be a member of KDE forums since 2008-Oct.
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
The shortcuts name is "Suspend compositing" according to the source code. Looking in system settings this shortcut combo is Alt + Shift + F12 by default.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar Zarin
KDE Developer
Posts
345
Karma
8
OS
There is currently a bug that prevents OpenGL applications from running at full speed in KWin if you have disabled effects without restarting KWin. You will need to disable effects either in system settings or the config file (Not use the shortcut, dunno how the Plasmoid works) then restart KWin in a terminal/KRunner by typing `kwin --replace &`.

Last edited by Zarin on Wed Dec 24, 2008 2:10 am, edited 1 time in total.
Aether
Registered Member
Posts
2
Karma
0
OS
I would like an option to disable the feature that automatically disables compositing. It always disables when I don't want it to (like I'm using the zoom feature on a low power GPU but I just want to be able to read my screen from a distance - better DPI control would also fix this...). Give the user the choice.
User avatar Zarin
KDE Developer
Posts
345
Karma
8
OS
System settings -> Desktop -> Advanced -> Disable functionality checks.

 
Reply to topic

Bookmarks



Who is online

Registered users: ahmadmt, Baidu [Spider], Bing [Bot], Google [Bot], Graham Perrin, grumpfel, howtokdenlive, jmacleod, PhobosK, radoeka, Yahoo [Bot]