Reply to topic

KWin compositing only in XRender mode / unable to use OpenGL

blq
Registered Member
Posts
5
Karma
0
OS
Hi,

somehow I am unable to activate kwin4 compositing in OpenGL mode. If I try to I get the following message:

"Failed to activate desktop effects using the given configuration options. Settings will be reverted to their previous values.

Check your X configuration. You may also consider changing advanced options, especially changing the compositing type."



I have a NVidia GF GTX+ 9800 connected to 2 monitors in twinview.

Code: Select all
Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "DamageEvents" "True"
    Option         "RenderAccel" "True"
    Option         "AllowGLXWithComposite" "True"
    Option         "TwinView" "1"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "CRT-0: nvidia-auto-select +0+0, CRT-1: nvidia-auto-select +1600+0"
    Option         "AddARGBGLXVisuals" "True"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection



I've turned xdamage and xcomposite on.

Code: Select all
Section "Extensions"
    Option         "Composite" "True"
    Option         "DAMAGE" "True"
    Option         "RENDER" "True"
EndSection


I made sure I am not in failsafe mode.

glxinfo says:
direct rendering: Yes

glxgears:
75516 frames in 5.0 seconds = 15103.146 FPS
85523 frames in 5.0 seconds = 17104.479 FPS
77216 frames in 5.0 seconds = 15443.117 FPS


Xorg.0.log says:
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: X.Org Server Extension
(II) NVIDIA GLX Module 190.42 Tue Oct 20 21:19:30 PDT 2009
(II) Loading extension GLX

(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
compiled for 1.7.1, module version = 1.0.0
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
compiled for 1.7.1, module version = 1.1.0
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2

(**) NVIDIA(0): Option "RenderAccel" "True"
(**) NVIDIA(0): Option "TwinView" "1"
(**) NVIDIA(0): Option "MetaModes" "CRT-0: nvidia-auto-select +0+0, CRT-1: nvidia-auto-select +1600+0"
(**) NVIDIA(0): Option "TwinViewXineramaInfoOrder" "CRT-0"
(**) NVIDIA(0): Option "AllowGLXWithComposite" "True"
(**) NVIDIA(0): Option "AddARGBGLXVisuals" "True"
(**) NVIDIA(0): Option "DamageEvents" "True"
(**) Nov 16 14:44:15 NVIDIA(0): Enabling RENDER acceleration
(II) Nov 16 14:44:15 NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) Nov 16 14:44:15 NVIDIA(0): enabled.

(II) Nov 16 14:44:16 NVIDIA(0): Initialized OpenGL Acceleration
(==) NVIDIA(0): Disabling shared memory pixmaps
(II) Nov 16 14:44:16 NVIDIA(0): Initialized X Rendering Acceleration

(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing extension GLX




I think I've the latest drivers and software installed.
nvidia 190.42-1
xorg-server 1.7.1.901-2
kdebase-workspace 4.3.3-1


xorg.conf: http://longint.de/~blq/xorg.conf
.xsession-errors: http://longint.de/~blq/xsession-errors
Xorg.0.log: http://longint.de/~blq/Xorg.0.log
glxinfo: http://longint.de/~blq/glxinfo.output


What else could I check? Any suggestions?

Thanks in advance.
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
Are you using the latest version of the NVidia drivers for your card? Some older versions are blacklisted due to their instability with KWin effects.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
blq
Registered Member
Posts
5
Karma
0
OS
bcooksley wrote:Are you using the latest version of the NVidia drivers for your card? Some older versions are blacklisted due to their instability with KWin effects.


blq wrote:I think I've the latest drivers and software installed.
nvidia 190.42-1
xorg-server 1.7.1.901-2
kdebase-workspace 4.3.3-1


So I'd say, yes I do :)
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
Try removing $(kde4-config --localprefix)/share/config/kwin* in case a configuration file contains an old setting preventing you from activating them. Also, you may wish to try disabling TwinView ( just to see if that makes a difference )


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
blq
Registered Member
Posts
5
Karma
0
OS
bcooksley wrote:Try removing $(kde4-config --localprefix)/share/config/kwin* in case a configuration file contains an old setting preventing you from activating them. Also, you may wish to try disabling TwinView ( just to see if that makes a difference )


ok, I removed all the kwin files out of the config folder and also disabled twinview, its still the same behavior :/
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
I asked on the KWin IRC channel, and they recommended you try backing up xorg.conf and removing it, and letting X automatically determine everything.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
blq
Registered Member
Posts
5
Karma
0
OS
Without a xorg.conf I was only able to run kde at super low resolution and compositing still didnt work.

Thanks anyway!
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
Can you try again ( this time with the xorg.conf ) but remove the XDAMAGE related parts?


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
blq
Registered Member
Posts
5
Karma
0
OS
This doesn't work either.

But I found out that compiz-fusion works. How can I be sure that compiz-fusion really used OpenGL instead of XRender? It felt a bit slow, so I'm not sure if it really worked.

I don't think about compiz-fusion as a solution but as a way to narrow down where the problem comes from.
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
I spoke with a KWin developer ( who also uses NVidia ) and they use the following xorg.conf, and it works for them - http://pastebin.ca/1685021


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar Paulfocused
Registered Member
Posts
31
Karma
0
OS
I actually had this same problem with my Intel card in 4.3.1 (I believe I using sid at the time) but I don't remember how I fixed it....Sorry I couldn't help :(


mikerichardson
Registered Member
Posts
2
Karma
0
OS
Hi,

Has anyone been able to find a solution to this problem? I'm having the exact same issue with 4.3 on Kubuntu 9.10. Compiz seems to work better, but I'd much prefer to have KWin and OpenGL.

Tnx
mikerichardson
Registered Member
Posts
2
Karma
0
OS
So I found that if I disable TwinView and just go to one one screen, then Kwin works flawelessly. As such as I turn on TwinView again, it fails :(
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
Since you are using KDE 4.3, it is likely you have found a bug in the operation of KWin's desktop effects with multiple screens ( probably due to the lack of using Kephal )

Please file a bug at bugs.kde.org.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], ipwizard, joaoherberto, malarkey, Sogou [Bot], Yahoo [Bot]