Reply to topic

Maximize Emacs

ravi.xolve
Registered Member
Posts
28
Karma
1
OS

Maximize Emacs

Fri Mar 11, 2011 10:21 am
I cannot maximize emacs. When I press the maximize button emcas cover all of the screen except the right and bottom borders. :'(

Please tell a solution to this.

Last edited by ravi.xolve on Mon May 30, 2011 4:16 pm, edited 1 time in total.
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS

Re: Maximize Emacs

Fri Mar 11, 2011 10:55 pm
Do you have panels on the bottom and right of the screen? Areas covered by panels cannot have applications maximised over them. Please provide a screenshot to explain further.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar Hans
Administrator
Posts
3304
Karma
24
OS

Re: Maximize Emacs

Sat Mar 12, 2011 12:31 am
My guess is that Emacs only allows sizes with an integer value of number of rows/columns (GVim behaves this way). I assume that you use the graphical version of Emacs, is that correct? Unfortunately I don't know a workaround if that's the case.


Problem solved? Please click on "Accept this answer" below the post with the best answer to mark your topic as solved.

10 things you might want to do in KDE | Open menu with Super key | Mouse shortcuts
kvazary
Registered Member
Posts
7
Karma
0
OS

Re: Maximize Emacs

Mon Apr 11, 2011 9:47 pm
Quite late reply but since this was bugging me since the days I used emacs(KDE 4.3) now bugging me with gvim...finaly I dig in the window menu...as workaround go to window menu->advanced->special application settings->workarounds and set strictly obey geometry to force, this will add padding to your editor window so it will be in maximize state(don't know from how long this option is present, or I didn't know for what it is if I look it before). There's no way except one to love all this KWin options :)
User avatar ychaouche
Registered Member
Posts
32
Karma
0
OS

Re: Maximize Emacs

Wed Nov 09, 2011 11:00 am
Thank you so much for this trick, it works great to demaximize emacs (alt-F10 / alt-F10).

 
Reply to topic

Bookmarks



Who is online

Registered users: abdu, Baidu [Spider], Bing [Bot], bogkuz, fredrikson, Google [Bot], ipwizard, jmacleod, koffeinfriedhof, markhm, Paul, Sogou [Bot], ulim, vincechenal