Reply to topic

Transcode tracks dialog doesn't pop up

msoldani
Registered Member
Posts
7
Karma
0
I've installed Kubuntu 14.04 and Amarok 2.8.0. When I copy tracks to a USB the transcode tracks dialog doesn't pop up. The file is copied without any transcoding.
Any idea to fix the issue?
Thanks

Mauro
User avatar Mamarok
Manager
Posts
3119
Karma
8
OS
How do you try to copy you tracks?


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Utopic 14.10 KDE 4.14.2, Amarok 2.8-git of the day
msoldani
Registered Member
Posts
7
Karma
0
First I connect a USB memory then I click right on the track to select "copy" or "move to collection" to the USB memory but no dialog "transcode track" pop up. The "copy" or "move" process start immediatelly without any transcoding for example from flac to mp3
Thanks

Mauro
User avatar Mamarok
Manager
Posts
3119
Karma
8
OS
Do you have all the necessary codecs installed? Sounds to me like you are missing something there. In particular please check if you have the following packages installed:

* libav-tools
* libavbin0
* flac and libflac
* libmp3lame0
* libvorbis0a
* libfaac0


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Utopic 14.10 KDE 4.14.2, Amarok 2.8-git of the day
msoldani
Registered Member
Posts
7
Karma
0
Could you please let me know how I can verify if these packages are installed and in case not the procedure to do it?
Any reference to a web page where I can get this info is very welcome.
I appreciate.
Thanks

Mauro
User avatar Mamarok
Manager
Posts
3119
Karma
8
OS
Erm, check with your Package Manager?


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Utopic 14.10 KDE 4.14.2, Amarok 2.8-git of the day
msoldani
Registered Member
Posts
7
Karma
0
I've checked and the packages were not installed. I did it but transcoding still not working. Trackes are copied to a USB memory without poping up the transcoding dialog.

Thanks

Mauro
User avatar Mamarok
Manager
Posts
3119
Karma
8
OS
Did you reload Amarok, eventually also KDE? For new packages to become active in applications that depend upon you need to restart the application. Since ffmpeg (libav) is active system-wide you will probably also have to restart your computer.


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Utopic 14.10 KDE 4.14.2, Amarok 2.8-git of the day
wolfi323
Registered Member
Posts
471
Karma
2
OS
msoldani wrote:Trackes are copied to a USB memory without poping up the transcoding dialog.

That dialog has a setting "Remember this choice for the next time", maybe you activated this by mistake?
This is saved in a file ".isaudioplayer" on your USB stick. Try to open the stick in dolphin f.e. and remove that file.
Please note, that you might have to activate the option "Show hidden files" first to see that file.

If that doesn't help, try to create a new user and login as that to find out whether it's a system-wide installation issue (like missing codec support as was suggested), or rather caused by some user settings.
msoldani
Registered Member
Posts
7
Karma
0
I've restarted my computer but the transcoding dialog doesn't pop up.
I've used different USB stick but the problem is still present. I've formatted one USB stick Fat 32 without solving the issue.
I logged as Guest with no results.
Thanks

Mauro
User avatar Mamarok
Manager
Posts
3119
Karma
8
OS
Could you please close Amarok, remove this file and restart Amarok afterwards:

~/.kde/share/config/amarokrc


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Utopic 14.10 KDE 4.14.2, Amarok 2.8-git of the day
wolfi323
Registered Member
Posts
471
Karma
2
OS
AFAIK Amarok needs the "ffmpeg" executable for that dialog to show up.

What happens if you type "ffmpeg" into a terminal window?

This should help you to get ffmpeg if you don't have it:
http://askubuntu.com/questions/432542/i ... s-in-14-04

Or try to symlink ffmpeg to avconv:
Code: Select all
sudo ln -s /usr/bin/avconv /usr/bin/ffmpeg

I can't test if that would work though, I have ffmpeg installed, not libav/avconv.
msoldani
Registered Member
Posts
7
Karma
0
1. on the search bar of Dolphin I've dialed "/.kde/share/config/amarokrc" first and then just "amarokrc" both on Home and Root directory selecting "everywhere" but no item found.

2. Using Moun Package Manager I've installed all the packages with "ffmpeg". After that typing "ffmpeg" into a terminal window I got:
"mauro@mauro-PC:~$ ffmpeg
avconv version 9.11-6:9.11-2ubuntu2, Copyright (c) 2000-2013 the Libav developers
built on Mar 24 2014 06:12:33 with gcc 4.8 (Ubuntu 4.8.2-17ubuntu1)
Hyper fast Audio and Video encoder
usage: avconv [options] [[infile options] -i infile]... {[outfile options] outfile}...

Use -h to get full help or, even better, run 'man avconv'"

3. Used "sudo ln -s /usr/bin/avconv /usr/bin/ffmpeg"

4. Followed the instruction on "http://askubuntu.com/questions/432542/i ... s-in-14-04" and downloaded "/ffmpeg/ffmpeg.static.64bit.latest" and run in Konsole "ffmpeg" and "ffprobe" with the following feedback:

"ffmpeg version N-62857-gfeaa31d Copyright (c) 2000-2014 the FFmpeg developers
built on May 1 2014 05:35:16 with gcc 4.6 (Debian 4.6.3-1)
configuration: --prefix=/root/ffmpeg-static/64bit --extra-cflags='-I/root/ffmpeg-static/64bit/include -static' --extra-ldflags='-L/root/ffmpeg-static/64bit/lib -static' --extra-libs='-lxml2 -lexpat -lfreetype' --enable-static --disable-shared --disable-ffserver --disable-doc --enable-bzlib --enable-zlib --enable-postproc --enable-runtime-cpudetect --enable-libx264 --enable-gpl --enable-libtheora --enable-libvorbis --enable-libmp3lame --enable-gray --enable-libass --enable-libfreetype --enable-libopenjpeg --enable-libspeex --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-version3 --enable-libvpx
libavutil 52. 80.100 / 52. 80.100
libavcodec 55. 60.100 / 55. 60.100
libavformat 55. 37.101 / 55. 37.101
libavdevice 55. 13.100 / 55. 13.100
libavfilter 4. 4.100 / 4. 4.100
libswscale 2. 6.100 / 2. 6.100
libswresample 0. 18.100 / 0. 18.100
libpostproc 52. 3.100 / 52. 3.100
Hyper fast Audio and Video encoder
usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...

Use -h to get full help or, even better, run 'man ffmpeg'"


"ffprobe version N-62857-gfeaa31d Copyright (c) 2007-2014 the FFmpeg developers
built on May 1 2014 05:35:16 with gcc 4.6 (Debian 4.6.3-1)
configuration: --prefix=/root/ffmpeg-static/64bit --extra-cflags='-I/root/ffmpeg-static/64bit/include -static' --extra-ldflags='-L/root/ffmpeg-static/64bit/lib -static' --extra-libs='-lxml2 -lexpat -lfreetype' --enable-static --disable-shared --disable-ffserver --disable-doc --enable-bzlib --enable-zlib --enable-postproc --enable-runtime-cpudetect --enable-libx264 --enable-gpl --enable-libtheora --enable-libvorbis --enable-libmp3lame --enable-gray --enable-libass --enable-libfreetype --enable-libopenjpeg --enable-libspeex --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-version3 --enable-libvpx
libavutil 52. 80.100 / 52. 80.100
libavcodec 55. 60.100 / 55. 60.100
libavformat 55. 37.101 / 55. 37.101
libavdevice 55. 13.100 / 55. 13.100
libavfilter 4. 4.100 / 4. 4.100
libswscale 2. 6.100 / 2. 6.100
libswresample 0. 18.100 / 0. 18.100
libpostproc 52. 3.100 / 52. 3.100
Simple multimedia streams analyzer
usage: ffprobe [OPTIONS] [INPUT_FILE]

You have to specify one input file.
Use -h to get full help or, even better, run 'man ffprobe'."

Since I'm not an expert I don't know what to do next.
I reboot the PC but the problem is still present.

I've downloaded again Kubuntu OS from the site www.kubuntu.org and installed in a USB pen to verify if the problem was related to the OS installation on my PC. Even launching Kubuntu/Amarok from memory stick no transcoding dialog pop up but.

I've decided to use Kubuntu because Amarok did not work very well with Ubuntu but the transcoding worked fine.
msoldani
Registered Member
Posts
7
Karma
0
I've installed Amarok in Window 7 and even with this OS the transcode track dialog doesn't pop up. Could the problem be Amarok itself? the new version?

Thanks

Mauro
User avatar Mamarok
Manager
Posts
3119
Karma
8
OS
You are comparing apples with oranges, there, as ffmpeg is not available on Windows AFAIK so the transcoding feature can't work on that OS.

I have forwarded the question to the Kubuntu developers, as something must be wrong on that level, I see no transcoding issues with current Amarok from git (which is ahead of version 2.8.0 by over 300 commits) on Kubuntu 14.04, and I don't remember any reports from users before 14.04 with Amarok 2.8. about this.


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu Utopic 14.10 KDE 4.14.2, Amarok 2.8-git of the day

 
Reply to topic

Bookmarks



Who is online

Registered users: andreas_k, awill, Baidu [Spider], Bing [Bot], boudewijn, donniezazen, eagleton, einar, Exabot [Bot], Google [Bot], koriun, korsakoff, Mamarok, milliams, MSNbot Media, mykolak, notmart, paulus3005, ripper17, sdh, simonv, sinclair, smankowski, weaktransform, Xiceph, Yahoo [Bot]