Reply to topic

Unable to play mp3 files in Amarok

kde-deshmukh
Registered Member
Posts
172
Karma
0

Unable to play mp3 files in Amarok

Fri Apr 29, 2016 3:36 pm
Running Amarok 2.8.0.

I am unable to play mp3 files. gstreamer good, bad, ugly all are installed. And FWIW, Dragon Player is unable to play mp4s also.

Here is the relevant part from .xsession-errors:

** Message: PackageKit: Codec nice name: MPEG-1 Layer 3 (MP3) decoder
** Message: PackageKit: ignoring field named parsed
** Message: PackageKit: field is: mpegversion, type: gint
** Message: PackageKit: field is: layer, type: gint
** Message: PackageKit: structure: gstreamer1(decoder-audio/mpeg)(mpegversion=1)(layer=3)()(64bit)
** Message: PackageKit: Did not install codec: GDBus.Error:org.freedesktop.DBus.Error.UnknownInterface: No such interface 'org.freedesktop.PackageKit.Modify2' at object path '/org/freedesktop/PackageKit'

What do I need to do to get this working?


--
Manjaro Gnome. Kernel 4.19.24-1. 64-bit. 4GB RAM and more than 100GB free on the hard disk.
User avatar google01103
Manager
Posts
6668
Karma
25
look for gstreamer-*fluendo* packages and install them


OpenSuse Leap 42.1 x64, Plasma 5.x

kde-deshmukh
Registered Member
Posts
172
Karma
0
google01103 wrote:look for gstreamer-*fluendo* packages and install them


dnf search fluendo returns:

Last metadata expiration check: 5 days, 16:22:00 ago on Sun Apr 24 19:30:19 2016.
========================================== Matched: fluendo ===========================================
schroedinger.x86_64 : Portable libraries for the high quality Dirac video codec
schroedinger.i686 : Portable libraries for the high quality Dirac video codec

dnf search gstreamer | grep fluendo returns nothing.


--
Manjaro Gnome. Kernel 4.19.24-1. 64-bit. 4GB RAM and more than 100GB free on the hard disk.
User avatar Mamarok
Manager
Posts
3900
Karma
11
OS
You should ask the Fedora people, as this seems to be a problem with your distribution.


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu 19.10, Plasma 5.17.3, Frameworks 5.64.0, Qt 5.12.4, kernel 5.3.0-23
User avatar google01103
Manager
Posts
6668
Karma
25


OpenSuse Leap 42.1 x64, Plasma 5.x

kde-deshmukh
Registered Member
Posts
172
Karma
0


phonon-backend-gstreamer is installed already. :(


--
Manjaro Gnome. Kernel 4.19.24-1. 64-bit. 4GB RAM and more than 100GB free on the hard disk.
kde-deshmukh
Registered Member
Posts
172
Karma
0
Found the answer by accident. Hope the documentation were better.

Amarok -> Settings -> Configure Amarok -> Playback -> Configure Phonon (misnomer) -> Backend -> Prefer VLC and defer Gstreamer.

Log out, log back in and you are done.


--
Manjaro Gnome. Kernel 4.19.24-1. 64-bit. 4GB RAM and more than 100GB free on the hard disk.
User avatar google01103
Manager
Posts
6668
Karma
25
http://www.abouthack.com/2016/01/playin ... -fedora-23
Fedora 23 does not ship with mp3 and many other multimedia codec for copyright issues. But there are many ways to play mp3 on fedora 23.


so if you were using the std gstreamer packages shipped with Fedora you wouldn't be able to play mp3s


OpenSuse Leap 42.1 x64, Plasma 5.x


 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Belliric, Bing [Bot], Google [Bot], Kresimir, Majestic-12 [Bot], Yahoo [Bot]