Topic locked

Amarok 2.2.2

User avatar echoes
Registered Member
Posts
107
Karma
0
OS

Re: Amarok 2.2.2

Tue Feb 16, 2010 12:15 am
Mamarok wrote:It would be nice if you could do only one thing before pasting the ouput, since it seems to do a lot of other things besides mounting a CD:

1. Start Amarok from the konsole with "amarok -d > log.txt 2>&1"
2. Put a CD in the CD tray and wait til it shows up in the Local Music section
3. Double click on the CD header to add it to the playlist
4. Try to play a track or two, then stop Amarok
5. Paste the log.txt in http://pastebin.ca


I know what you mean, a lot of the info looked superfluous to this problem. However, I thought I did just what you said. Any way, here is the output of that:

http://pastebin.ca/1797826

Although, steps #3 & 4 are not applicable because Amarok still shows zero tracks on all audio CDs.

I hope it is helpful though.

P.S. I'm now using amarok-2.2.90-57.1 from the KDE:KDE4:FACTORY:Desktop repository.
User avatar Mamarok
Manager
Posts
6042
Karma
16
OS

Re: Amarok 2.2.2

Tue Feb 16, 2010 8:26 am
Code: Select all
amarok(30956)/kio (KIOJob) KIO::SlaveInterface::dispatch: error  163   "Device does not have read permissions for this account.  Check the read permissions on the device."

You should go through your system/user permissions, something is fishy there.


Running Kubuntu 22.04 with Plasma 5.24.5, Frameworks 5.95.0, Qt 5.15.3, kernel 5.15.0-37 on Ryzen 5 4600H, AMD Renoir, X11
FWIW: it is always useful to state the exact Plasma version (+ distribution) when asking questions, makes it easier to help ...
User avatar echoes
Registered Member
Posts
107
Karma
0
OS

Re: Amarok 2.2.2

Wed Feb 17, 2010 7:34 pm
Mamarok wrote:
Code: Select all
amarok(30956)/kio (KIOJob) KIO::SlaveInterface::dispatch: error  163   "Device does not have read permissions for this account.  Check the read permissions on the device."

You should go through your system/user permissions, something is fishy there.


I hadn't noticed that! Thanks for catching it. I made a change that will hopefully fix this issue but I can't report the result until later today because I can't test it until then.
User avatar echoes
Registered Member
Posts
107
Karma
0
OS

Re: Amarok 2.2.2

Thu Feb 18, 2010 5:51 am
UPDATE:

I tried adding myself to the cdrom group (the group which my sole disc drive is in) but that did not help.

So I looked at the permissions of the device (sr0) and they looked fine (myself as a member of "cdrom" was allowed) but "Others" were forbidden from the device. So I allowed them and viola, Amarok could then detect my audio cd tracks.

However, the problem is now that Amarok refuses to actually play the tracks. No audio is produced (audio & audio cds work fine in other apps, such as Audacious), progress bar does not progress, however, Amarok "acts" as if it is playing the track because the right-click menu shows "Stop" instead of play.

Here is the output:

http://pastebin.ca/1801150
User avatar Mamarok
Manager
Posts
6042
Karma
16
OS

Re: Amarok 2.2.2

Thu Feb 18, 2010 8:55 am
"Other apps" don't use Phonon. Make sure you use the phonon-backend-xine and have the necessary codecs for libxine installed. Most distributions don't include those codecs for patent reasons, so you have to install those by yourself.


Running Kubuntu 22.04 with Plasma 5.24.5, Frameworks 5.95.0, Qt 5.15.3, kernel 5.15.0-37 on Ryzen 5 4600H, AMD Renoir, X11
FWIW: it is always useful to state the exact Plasma version (+ distribution) when asking questions, makes it easier to help ...
User avatar echoes
Registered Member
Posts
107
Karma
0
OS

Re: Amarok 2.2.2

Fri Feb 19, 2010 8:10 am
Mamarok wrote:"Other apps" don't use Phonon. Make sure you use the phonon-backend-xine and have the necessary codecs for libxine installed. Most distributions don't include those codecs for patent reasons, so you have to install those by yourself.


I'm well aware of all of that. I know other apps don't use Phonon but other apps do play audio & audio cds fine which is why I mentioned it.

I do have the xine backend installed as well as the gstreamer backend. I also have all the xine & gstreamer codecs/plugins installed.
User avatar Mamarok
Manager
Posts
6042
Karma
16
OS

Re: Amarok 2.2.2

Fri Feb 19, 2010 9:26 am
Code: Select all
amarok: BEGIN: void Playlist::PrettyListView::trackActivated(const QModelIndex&)
amarok:   BEGIN: void Playlist::Actions::play(quint64, bool)
amarok:     BEGIN: void EngineController::play(const Meta::TrackPtr&, uint)
amarok:       [EngineController] Just a normal, boring track... :-P
amarok:       BEGIN: void EngineController::playUrl(const KUrl&, uint)
amarok:         [EngineController] URL:  "audiocd:/ad126c0d/3"
amarok:         [EngineController] offset:  0
amarok:         [EngineController] play track from cd
amarok:         [EngineController] 3.2.1...
amarok:         [EngineController] boom?
amarok:         [EngineController] no boom?
amarok:         [EngineController] track pos after play:  -1
amarok:       END__: void EngineController::playUrl(const KUrl&, uint) - Took 0.00026s
amarok:     END__: void EngineController::play(const Meta::TrackPtr&, uint) - Took 0.00038s
amarok:   END__: void Playlist::Actions::play(quint64, bool) - Took 0.00058s
amarok: END__: void Playlist::PrettyListView::trackActivated(const QModelIndex&) - Took 0.00072s

No idea why the EngineController causes problems here, I will have to ask the devs.


Running Kubuntu 22.04 with Plasma 5.24.5, Frameworks 5.95.0, Qt 5.15.3, kernel 5.15.0-37 on Ryzen 5 4600H, AMD Renoir, X11
FWIW: it is always useful to state the exact Plasma version (+ distribution) when asking questions, makes it easier to help ...

 
Topic locked

Bookmarks



Who is online

Registered users: Bing [Bot], claydoh, Google [Bot], markhm, navitatis, Sogou [Bot], Yahoo [Bot]