Topic locked

2.4 for Lucid (Kubuntu 10.4) now available

User avatar google01103
Manager
Posts
6668
Karma
25
If people running Lucid and wishing to run Amarok 2.4 would be willing to test a newly created package please do so and report on problems here

Just enable backports and 2.4 should be available or you can just download the Amarok package if you don't want the other stuff in backports

How to use backports: https://help.ubuntu.com/community/Ubunt ... 20to%20use


OpenSuse Leap 42.1 x64, Plasma 5.x

Shadeslayer
Registered Member
Posts
3
Karma
0
OS
Hi
I've just installed amarok from the staging repo in a clean chroot and there should be no need of enabling the Backports repo, sorry for the confusion :)
User avatar claydoh
Registered Member
Posts
1110
Karma
9
OS
Please note that you should either manually download the amarok packages, or disable the PPA after installing it.

The staging PPA is used to build packages before they are moved over to the normal PPA's. if you don't, you could get partial/incomplete KDE upgrades due to this.

https://launchpad.net/~kubuntu-ppa/+archive/staging


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
Shadeslayer
Registered Member
Posts
3
Karma
0
OS
Ok, even better news, i got it into the Ubuntu Backports Archive : https://launchpad.net/ubuntu/+source/am ... tu4~lucid1
User avatar google01103
Manager
Posts
6668
Karma
25
claydoh wrote:Please note that you should either manually download the amarok packages, or disable the PPA after installing it.

The staging PPA is used to build packages before they are moved over to the normal PPA's. if you don't, you could get partial/incomplete KDE upgrades due to this.

https://launchpad.net/~kubuntu-ppa/+archive/staging


has been added to backports, staging no longer needed (1st post changed to reflect this)

claydoh - did it work ok for you?


OpenSuse Leap 42.1 x64, Plasma 5.x

User avatar przxqgl
Registered Member
Posts
11
Karma
0
OS
i've added
Code: Select all
deb http://archive.ubuntu.com/ubuntu lucid-backports main universe multiverse restricted
to my
Code: Select all
/etc/apt/sources.list
(it was already there to start with), and after i type
Code: Select all
sudo apt-get update
and
Code: Select all
sudo apt-get -f dist-upgrade
i get:

Code: Select all
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


and i've still got amarok 2.3.2...

what am i doing wrong? :-/
User avatar google01103
Manager
Posts
6668
Karma
25
przxqgl - maybe it takes time to propagate thru the repositories?

these are the links for the 3 individual packages (i386)
https://launchpad.net/ubuntu/lucid/i386 ... tu4~lucid1
https://launchpad.net/ubuntu/lucid/i386 ... tu4~lucid1
https://launchpad.net/ubuntu/lucid/i386 ... tu4~lucid1
maybe install manually


OpenSuse Leap 42.1 x64, Plasma 5.x

User avatar claydoh
Registered Member
Posts
1110
Karma
9
OS
google01103 wrote:
claydoh wrote:Please note that you should either manually download the amarok packages, or disable the PPA after installing it.

The staging PPA is used to build packages before they are moved over to the normal PPA's. if you don't, you could get partial/incomplete KDE upgrades due to this.

https://launchpad.net/~kubuntu-ppa/+archive/staging


has been added to backports, staging no longer needed (1st post changed to reflect this)

claydoh - did it work ok for you?


I am not currently running Lucid anywhere, but actually I should have known he'd get Amarok into the official backports :) Those Kubuntu Ninjas have the chops.
I was going to give it a go myself, but it would have had to wait until the weekend :/

great job, shadeslayer!!! And many thanks

Also thanks to Valorie for asking the right folks in the right place :D


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
User avatar przxqgl
Registered Member
Posts
11
Karma
0
OS
google01103 wrote:przxqgl - maybe it takes time to propagate thru the repositories?


apparently it does, because it's installing now...

and now i'm running 2.4.0! ;D you guys rock! thanks!

although my tracks are still all 0:00 duration, and it appears that the bar that tracks where you are in the song doesn't work any more...

it's all good... i can deal with it. ;)
valoriez
KDE CWG
Posts
625
Karma
3
OS
przxqgl, that sounds like a different difficulty, which we should be able to solve. Let's start a new thread for that, however. OK?
User avatar google01103
Manager
Posts
6668
Karma
25
przxqgl - how about renaming your db folder ~/.kde/share/apps/amarok/mysqle and rescanning collection


OpenSuse Leap 42.1 x64, Plasma 5.x

User avatar przxqgl
Registered Member
Posts
11
Karma
0
OS
@valoriez - don't need to.

@google01103 - that did it... thanks again.

have i mentioned how much you guys rock? ;D
User avatar google01103
Manager
Posts
6668
Karma
25
yes, but keep reminding us as it goes to heads and makes us euphoric


OpenSuse Leap 42.1 x64, Plasma 5.x


 
Topic locked

Bookmarks



Who is online

Registered users: akselmo, Bing [Bot], driveprogramming, enricmetall, Google [Bot], q.ignora, Sogou [Bot], Will_S.