Reply to topic

Help us test OSX test build that fixes OpenGL issues

User avatar boudewijn
KDE Developer
Posts
4812
Karma
20
OS
See https://krita.org/en/item/experimental- ... available/ -- basically, this is the place where OSX users should report and discuss their experiences with the special disk image we created after fixing Qt to support OSX's OpenGL implementation. All Krita's opengl-related features (wraparound mode, high-quality scaling, canvas rotating and mirroring) should work, all the tools should show their decorations correctly, Wacom tablets should work fine.

UPDATE: this new build includes all 3.0.1 fixes and an extra fix for the HUD crash. It also should actually be packaging a correct build from the correct branch...

Here's the image: http://files.kde.org/krita/3/osx/devbui ... nimmy2.dmg

Note: this image is not a full 3.0.1, it is missing some functionality and bug fixes compared to 3.0.1, but those are not OSX specific.

Last edited by boudewijn on Wed Sep 07, 2016 2:59 pm, edited 2 times in total.
User avatar boudewijn
KDE Developer
Posts
4812
Karma
20
OS
One interesting thing is to start krita from the command line: open the terminal app, navigate to where you copied Krita from the DMG and start krita like this:

$ ./krita/app/Contents/MacOS/krita

That will print out lots of stuff, including what Qt has detected about the opengl settings. For me this is:

OpenGL Info
Vendor: Intel Inc.
Renderer: Intel Iris Pro OpenGL Engine
Version: 4.1 INTEL-10.14.66
Shading language: 4.10
Requested format: QSurfaceFormat(version 3.2, options QFlags(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples -1, swapBehavior 2, swapInterval 0, profile 1)
Current format: QSurfaceFormat(version 4.1, options QFlags(), depthBufferSize 24, redBufferSize 8, greenBufferSize 8, blueBufferSize 8, alphaBufferSize -1, stencilBufferSize 8, samples -1, swapBehavior 2, swapInterval 1, profile 1)

(On 15" Macbook Pro Retina with El Capitan)
User avatar beelzy
Registered Member
Posts
25
Karma
0
OS
Here's my output: https://bpaste.net/show/a355e11376e1

It seems Krita is not trying hard enough to grab the OpenGL Core Profile, or what?

I'm on a Macbook Air with 8GB RAM. It supports OpenGL 4.1.
User avatar boudewijn
KDE Developer
Posts
4812
Karma
20
OS
Same on the Mac Mini:

OpenGL Info
Vendor: Intel Inc.
Renderer: Intel HD Graphics 3000 OpenGL Engine
Version: 2.1 INTEL-8.24.16
Shading language: 1.20
Requested format: QSurfaceFormat(version 2.1, options QFlags(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples -1, swapBehavior 2, swapInterval 0, profile 0)
Current format: QSurfaceFormat(version 2.1, options QFlags(0x4), depthBufferSize 24, redBufferSize 8, greenBufferSize 8, blueBufferSize 8, alphaBufferSize -1, stencilBufferSize 8, samples -1, swapBehavior 2, swapInterval 1, profile 0)
krita has opengl true

But there isn't much we can do. We ask for 3.2 Core Profile; if we ask for 3.0 Core Profile, what we get is 2.1 -- at least on the macbook pro.
jelenam
Registered Member
Posts
14
Karma
0
Thanks for the build. Is there anything special we should test? Or just use it as normal and post all bugs we find in this thread?

First bug: Trying to open the popup palette crashes the app (both with and without having OpenGL activated)
User avatar boudewijn
KDE Developer
Posts
4812
Karma
20
OS
No, only bugs that are related to the what this branch is about: the opengl display.
jelenam
Registered Member
Posts
14
Karma
0
All right.
kriiiiiiiiitakiiiiita
Registered Member
Posts
4
Karma
0
OS
I'm a new user and I'm not too tech savvy when it comes to OpenGl. So far, I have encountered no problems when using the program.
Here's the terminal info:
QCoreApplication::arguments: Please instantiate the QApplication object first
krita.lib.pigment: Compiled for arch: 7
krita.lib.pigment: Features supported:
krita.lib.pigment: "SSE2" --- yes
krita.lib.pigment: "SSSE3" --- yes
krita.lib.pigment: "SSE4.1" --- yes
krita.lib.pigment: "AVX " --- yes
krita.lib.pigment: "AVX2 " --- yes
Set style "fusion"
OpenGL Info
Vendor: Intel Inc.
Renderer: Intel(R) Iris(TM) Graphics 6100
Version: 2.1 INTEL-10.14.73
Shading language: 1.20
Requested format: QSurfaceFormat(version 2.1, options QFlags(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples -1, swapBehavior 2, swapInterval 0, profile 0)
Current format: QSurfaceFormat(version 2.1, options QFlags(0x4), depthBufferSize 24, redBufferSize 8, greenBufferSize 8, blueBufferSize 8, alphaBufferSize -1, stencilBufferSize 8, samples -1, swapBehavior 2, swapInterval 1, profile 0)
krita has opengl true
Setting XDG_DATA_DIRS "/Applications/krita.app/Contents/share"
Available translations QSet("be", "bg", "se", "mai", "fr", "oc", "sk", "[email protected]", "sl", "fy", "br", "bs", "sq", "nds", "sv", "ga", "kk", "km", "ko", "ca", "ta", "xh", "gl", "tg", "th", "pa", "ast", "cs", "tr", "pl", "cy", "hne", "he", "pt_BR", "pt", "da", "hi", "en_GB", "de", "zh_CN", "lt", "lv", "ug", "hr", "uk", "hu", "zh_TW", "ia", "mk", "uz", "mr", "ms", "is", "el", "vi", "it", "af", "eo", "nb", "es", "et", "eu", "ne", "ro", "ja", "ar", "nl", "[email protected]", "en_US", "ru", "nn", "fa", "wa", "fi")
Available domain translations QSet("be", "bg", "se", "mai", "fr", "oc", "sk", "[email protected]", "sl", "fy", "br", "bs", "sq", "nds", "sv", "ga", "kk", "km", "ko", "ca", "ta", "xh", "gl", "tg", "th", "pa", "ast", "cs", "tr", "pl", "cy", "hne", "he", "pt_BR", "pt", "da", "hi", "en_GB", "de", "zh_CN", "lt", "lv", "ug", "hr", "uk", "hu", "zh_TW", "ia", "mk", "uz", "mr", "ms", "is", "el", "vi", "it", "af", "eo", "nb", "es", "et", "eu", "ne", "ro", "ja", "ar", "nl", "[email protected]", "en_US", "ru", "nn", "fa", "wa", "fi")
Override language: ""
KoJsonTrader will load its plugins from "/Applications/krita.app/Contents/PlugIns"
libpng warning: iCCP: too many profiles
libpng warning: iCCP: too many profiles
libpng warning: iCCP: too many profiles
libpng warning: iCCP: too many profiles
"KConfigIni: In file /Applications/krita.app/Contents/Resources/krita_SRCS.icns, line 1: " Invalid entry (missing '=')
"KConfigIni: In file /Applications/krita.app/Contents/Resources/krita_SRCS.icns, line 2: " Invalid entry (missing '=')
"KConfigIni: In file /Applications/krita.app/Contents/Resources/krita_SRCS.icns, line 3: " Invalid entry (missing '=')
"KConfigIni: In file /Applications/krita.app/Contents/Resources/krita_SRCS.icns, line 4: " "Invalid escape sequence \"\\û\"."
"KConfigIni: In file /Applications/krita.app/Contents/Resources/krita_SRCS.icns, line 4: " "Invalid escape sequence \"\\¬\"."
"KConfigIni: In file /Applications/krita.app/Contents/Resources/krita_SRCS.icns, line 5: " "Invalid escape sequence \"\\c\"."
"KConfigIni: In file /Applications/krita.app/Contents/Resources/krita_SRCS.icns, line 5: " "Invalid escape sequence \"\\S\"."
"KConfigIni: In file /Applications/krita.app/Contents/Resources/krita_SRCS.icns, line 5: " "Invalid escape sequence \"\\é\"."
"KConfigIni: In file /Applications/krita.app/Contents/Resources/krita_SRCS.icns, line 5: " "Invalid escape sequence \"\\\u0013\"."
"KConfigIni: In file /Applications/krita.app/Contents/Resources/krita_SRCS.icns, line 5: " "Invalid escape sequence \"\\×\"."
"KConfigIni: In file /Applications/krita.app/Contents/Resources/krita_SRCS.icns, line 5: " "Invalid escape sequence \"\\,\"."
"KConfigIni: In file /Applications/krita.app/Contents/Resources/krita_SRCS.icns, line 5: " "Invalid escape sequence \"\\¾\"."
"KConfigIni: In file /Applications/krita.app/Contents/Resources/krita_SRCS.icns, line 5: " "Invalid escape sequence \"\\â\"."
"KConfigIni: In file /Applications/krita.app/Contents/Resources/krita_SRCS.icns, line 5: " "Invalid escape sequence \"\\X\"."
"KConfigIni: In file /Applications/krita.app/Contents/Resources/krita_SRCS.icns, line 8: " Invalid entry (missing ']')
"KConfigIni: In file /Applications/krita.app/Contents/Resources/krita_SRCS.icns, line 9: " Invalid entry (missing '=')
"KConfigIni: In file /Applications/krita.app/Contents/Resources/krita_SRCS.icns, line 11: " Invalid entry (missing ']')
"KConfigIni: In file /Applications/krita.app/Contents/Resources/krita_SRCS.icns, line 12: " Invalid entry (missing '=')
"KConfigIni: In file /Applications/krita.app/Contents/Resources/krita_SRCS.icns, line 13: " Invalid entry (missing '=')
"KConfigIni: In file /Applications/krita.app/Contents/Resources/krita_SRCS.icns, line 14: " Invalid entry (missing '=')
"KConfigIni: In file /Applications/krita.app/Contents/Resources/krita_SRCS.icns, line 15: " Invalid entry (missing '=')
"KConfigIni: In file /Applications/krita.app/Contents/Resources/krita_SRCS.icns, line 16: " Invalid entry (missing ']')
"KConfigIni: In file /Applications/krita.app/Contents/Resources/krita_SRCS.icns, line 18: " Invalid entry (missing ']')
"KConfigIni: In file /Applications/krita.app/Contents/Resources/krita_SRCS.icns, line 19: " Invalid entry (missing '=')
"KConfigIni: In file /Applications/krita.app/Contents/Resources/krita_SRCS.icns, line 21: " Invalid entry (missing '=')
"KConfigIni: In file /Applications/krita.app/Contents/Resources/krita_SRCS.icns, line 24: " Invalid entry (missing '=')
"KConfigIni: In file /Applications/krita.app/Contents/Resources/krita_SRCS.icns, line 25: " Invalid entry (missing '=')
"KConfigIni: In file /Applications/krita.app/Contents/Resources/krita_SRCS.icns, line 27: " Invalid entry (missing ']')
"KConfigIni: In file /Applications/krita.app/Contents/Resources/krita_SRCS.icns, line 28: " "Invalid escape sequence \"\\\u000F\"."

There's a thousand more "Invalid entry" lines for some reason. I'm using a 13" Retina Macbook Pro.
User avatar boudewijn
KDE Developer
Posts
4812
Karma
20
OS
Hm, all these Intel HD 3000, 5000, 6100 systems don't get OpenGL 3.2 or better -- that is not good.
kriiiiiiiiitakiiiiita
Registered Member
Posts
4
Karma
0
OS
What does that mean? It will be hard to optimise?
User avatar boudewijn
KDE Developer
Posts
4812
Karma
20
OS
No, it means there's something funky going on with the package I made -- which was missing one or two fixes in any case. I will update the build.
sinanh
Registered Member
Posts
25
Karma
0
Hi,

I have a MacBook Pro (13inch, Early 2015), 8GB Ram, Intel Core i5, Intel Iris Graphics 6100.

This build seems to work fine. I have enabled OpenGL (which I usually have off), and it seems to work.

Wrap around mode works, which didn't before, but "Instant Preview Mode" failed to activate.

I'll report any issues I find in this thread.
User avatar boudewijn
KDE Developer
Posts
4812
Karma
20
OS
Sinanh, is that with the beta-nimmy dmg or the nimmy2 dmg? If the former, please test the latter :-)
User avatar beelzy
Registered Member
Posts
25
Karma
0
OS
Can confirm the second build works. It's free of OpenGL patching problems, and instant preview works. My system may not have good enough specs to perhaps experience instant preview as it's intended to be used, but when you try to toggle it, it indicates that it's active/deactivated.
sinanh
Registered Member
Posts
25
Karma
0
@boudewijn

I was using "nimmy1" and Instant Preview failed to activate.

However, I just downloaded "nimmy2" and Instant Preview works! It says "Instant Preview is ON".

Wrap around mode works in both.

I should also say that I'm using OSX El Capitan 10.11.6. OSX Build: 15G1004.

In Krita, I have OpenGL ON, Trilinear Filtering ON, and "Use Texture Buffer" to ON.

Last edited by sinanh on Wed Sep 07, 2016 8:30 pm, edited 1 time in total.

 
Reply to topic

Bookmarks



Who is online

Registered users: allanmills, Baidu [Spider], Bing [Bot], boudewijn, ccarlo, cylverbak, dontdieych, Google [Bot], idyludic, ipwizard, raphaelra, Sogou [Bot], tymond