Reply to topic

Vector Libraries - I'm having problems making them

ahabgreybeard
Registered Member
Posts
680
Karma
7
OS
I'll try not to go into too much detail because there is lots of detail involved in making vector libraries.

I've been using Inkscape to try to make vector libraries for krita. The tutorials that I've watched and read are about making symbol sets for Inkscape, which is fine. After many false starts I finally thought I'd figured it out but I had duplicate entries in krita. I notice that the krita default vector libraries also have duplicate entries so maybe it's not just me who has problems.

I thought I'd figured out how to remove the duplicate enties, by deleting them from the Inkscape document after they'd been added to the symbol set, and this works but then I don't see all the items in krita even though they all show in the symbol set in Inkscape.

I have the most problems when I use .svg vector art that I get from the free download sites and also if I use the .svg files from the krita default libraries, trying to make a subset/mix composition.
I have fewer problems if I construct my own 'artwork' from scratch in Inkscape but I still have missing items in krita.

Is there any kind of tutorial or guide that anyone can recommend for making these libraries for use in krita?
ahabgreybeard
Registered Member
Posts
680
Karma
7
OS
I think I've figured it out:

No matter how 'grouped' an object is in the .svg Inkscape document, you have to select it and Group it again before you give it a title in the Object Properties editor (for the symbol name display in the krita Vector Library docker) then press Set and then add it to the Symbol List. Then you delete it from the document (it's still there as a symbol in the Symbol List).

If you don't delete the object from the document, you get it duplicated in the krita Vector Library. The displayed name of the Vector Library is determined by the Title of the document as set in the document Properties, Metadata tab.

Sometimes, if you add an object to the Symbol List it doesn't show in the displayed Document symbol collection. When that happens, don't panic and try adding it again; select a different symbol collection then select back to Document collection and it will appear.

It doesn't seem to matter if you Save it as Inkscape .svg format or Plain .svg. The Inkscape format has a slightly smaller file and a better looking internal layout.

I've raised a bug report about the duplicated items in the default vector libraries: https://bugs.kde.org/show_bug.cgi?id=406634
User avatar TheraHedwig
KDE Developer
Posts
1676
Karma
10
OS
Thanks, we been neckdeep in bugfixing here(in particular tablet bugs), so this slipped through the cracks :<

 
Reply to topic

Bookmarks



Who is online

Registered users: aperali, Baidu [Spider], Bing [Bot], claydoh, Exabot [Bot], ghevan, Google [Bot], jwt873, kuekue, lemjo, ramskulls, stanleyf, TheBeheader