Reply to topic

Different running applications in different activities?

benlz
Registered Member
Posts
4
Karma
0
Hi, there's something not clear to me about kde 4.9 activities.
When I use two or more activities, if I open, for example, dolphin or audacious, these are confined into the current activity. So I won't see them on the other activity's desktop.
But this is not true for ALL applications! For example, if I open Google Chrome into the current activity, I will see it into all the running activities... why?
Can I change this, to get Chrome running in only one activity?
benlz
Registered Member
Posts
4
Karma
0
I've an update: this happens only with windows without title bar (G. Chrome and some Wine applicatinons). It seems that kwin can't manage these windows, in fact Google Chrome works like I want (=doesn't appears in all the running activities) if I force it to use kwin's title bar.
That's not really a good news, because I use a small screen for kde, so I want Chrome to be without title bar... any ideas?
User avatar bcooksley
Administrator
Posts
19743
Karma
85
OS
Applications which are not being decorated by KWin are "unmanaged" - and thus are probably excluded from KWin's control, which would include window rules and activities I suspect. Not sure if there is anything that can be done in this case.


System Settings and Device Actions KCM maintainer
Image
luebking
Registered Member
Posts
1961
Karma
12
csousa
Registered Member
Posts
12
Karma
0
OS
I've just found a workaround for Chromium (and possibly for other applications without title bar)!

I also use Chromium without system title bar and it was getting spawned to all activities, not only the current one.

I was able to fix this behavior by:
creating a new "Window Rule" for Chromium (using the "Detect Window Properties" worked) and in the
"Appearance & Fixes"
tab checking
"No title bat and frame"
and setting it to
"Apply Initially": "No" .

Now, when a new Chromium is started, it appears only on the current activity and desktop, while still not using system title bar.

I'm using KDE 4.11.3 on Arch Linux.

Cheers,
Cristóvão
csousa
Registered Member
Posts
12
Karma
0
OS
Ok, I also had to do "apply initially" to "maximized" to avoid some quirks when opening multiple Chromium windows.
avilzzz
Registered Member
Posts
2
Karma
0
I was able to fix this behavior by:
creating a new "Window Rule" for Chromium (using the "Detect Window Properties" worked) and in the
"Appearance & Fixes"
tab checking
"No title bat and frame"
and setting it to
"Apply Initially": "No" .


Can someone please explain how\where to get into this dialog ?
Thanks,
User avatar google01103
Manager
Posts
5833
Karma
20
OS
avilzzz wrote:
I was able to fix this behavior by:
creating a new "Window Rule" for Chromium (using the "Detect Window Properties" worked) and in the
"Appearance & Fixes"
tab checking
"No title bat and frame"
and setting it to
"Apply Initially": "No" .


Can someone please explain how\where to get into this dialog ?
Thanks,

right click on title bar -> more actions -> special windows settings -> ........
or in the case of no title bar systemsettings -> window behavior -> window rules -> new -> detect window rules -> .....


OpenSuse 13.2 x64, KDE 4.14.x & Plasma 5.x

avilzzz
Registered Member
Posts
2
Karma
0
got it,
(and it works! although i don't understand why the window manager don't recognize the window without it)
thanks again
luebking
Registered Member
Posts
1961
Karma
12
although i don't understand why the window manager don't recognize the window without it


Because that's not the case - the behavior is actually intended (though afaiu it's only/mostly for plasma extenders and therefore personally consider it wrong)
Unmanaged windows (such as eg. popups or tooltips) could not be controlled through the rules at all (as the WM ignores them completely)

https://bugs.kde.org/show_bug.cgi?id=274931
fishb00n
Registered Member
Posts
2
Karma
0
Can someone please explain me how to get this working right? I recently started working with activities, and I have fallen in love with this, but I cannot live with the annoying title bar on chromium.
This is what I did:
Image

Image

Image

But when I start chromium, I get this:
Image

Of course, I can right click in the blue title area and select+deselect the option "Use system title bar and borders" which make the annoying bar go away, but when I close chromium and start it again, I have to do this again.

If I don't use this rule, chromium will by default show on all activities, which is also not what I want.. I hope someone can help me out.
luebking
Registered Member
Posts
1961
Karma
12
You should not need a rule for chromium at all - the "use system titlebar" setting of chrome is persistent and is sufficient to have the window decorated (thus not on all activities)
fishb00n
Registered Member
Posts
2
Karma
0
Well, I don't want the system titlebar. I thought that was what the original poster wanted as well. "Now, when a new Chromium is started, it appears only on the current activity and desktop, while still not using system title bar." -> That is exactly what I want, but I can get it working with these instructions.
luebking
Registered Member
Posts
1961
Karma
12
Ok, I misunderstood you then (and you misunderstood the OP ;-)

To be sure: "system titlebar" is the gray titlebar.
You can hide this titlebar from it's context mene (right MB, "Advanced Options") and/or bind a shortcut to that action.

To get what you want, a kwin script will be required...

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], capslock, davidemme, dpagoto, Exabot [Bot], Google [Bot], google01103, jmacleod, leromo, Majestic-12 [Bot], odysseus-art, rbruce, Sogatori, veqz, YaCy [Bot], Yahoo [Bot]