Reply to topic

[4.2]Linking activities to virtual desktops

User avatar einar
Administrator
Posts
2270
Karma
5
OS
If you have KDE 4.2 (trunk, or the betas) you may be interested in the fact that you can actually link a specific activity to a virtual desktop. This has been in the works and was also on the Feature Plan.

Notice: This feature is experimental and has no GUI option for it. It involves editing configuration files, so you may want to make backups before screwing your Plasma configuration.

That said, ensure that Plasma is not running: if you are in KDE, this can be accomplished by opening a terminal and writing

Code: Select all
kquitapp plasma


That will shut Plasma down nicely, and of course your desktop will disappear (but the terminal will still be open)

Now, edit the file $KDEHOME/share/config/plasmarc ($KDEHOME is .kde on Kubuntu 8.10+, .kde4 on openSUSE. I don't know about other distros). Inside, locate the [General] section. There, write

Code: Select all
perVirtualDesktopViews=true


Save the file and restart Plasma.

Last edited by einar on Mon Dec 29, 2008 2:35 pm, edited 1 time in total.


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
User avatar Primoz
Moderator
Posts
859
Karma
1
OS
OK it kind of works for me...
I have activity per desktop, but I also have more than just 4 activities, I actually have 13! activities.
One that I have before the whole massing with plasmarc and I guess the first 4 activities started when I started plasma again
But unfortunately I "bound" it with the console (forgot the & at the end) and when I quited Konsole the whole palasma died so I started it again.
And 4 more activities appeared. Then I decided to remove the added activities.
But while I was trying that my KWin died. So i had to restart the X and the last 4 activities appeared.
Is this because I added [general] myself there wasn't any before I added it.
I use Kubuntu 8.10 with KDE4.2beta2 (what else?)


Primoz, proud to be a member of KDE forums since 2008-Nov.
tleskac
Registered Member
Posts
1
Karma
0
Well I think it is a great idea , but it doesn't work! After changing plasmarc only first virtual desktop has wallpaper, the other ones are completly black and right click doesn't do anything. :-(
User avatar ivan
KDE Developer
Posts
771
Karma
13
OS
@tleskac
Well, that is the point of the /experimental/ attribute :)

Try going to the main virtual desktop, and create activities from there. (I haven't tested this, just guessing what could be the issue)

Last edited by ivan on Thu Jan 29, 2009 2:08 pm, edited 1 time in total.


Image
User avatar Primoz
Moderator
Posts
859
Karma
1
OS
tleskac wrote:Well I think it is a great idea , but it doesn't work! After changing plasmarc only first virtual desktop has wallpaper, the other ones are completly black and right click doesn't do anything. :-(


I get the same thing. But If you zoom out you'll see that there are other activities, but
if you try to zoom in on one of them you'll be thrown back to your main activity.
And If you log off and back in you'll see that there are more activities than they were before. They are spawning with every logout (or maybe with zoom out...).
Anyway this is one of my most wanted features, but unfortunately is not there yet.

Also did you have a General section in your plasmarc or did you had to add it, as I did?

Last edited by Primoz on Thu Jan 29, 2009 8:43 pm, edited 1 time in total.


Primoz, proud to be a member of KDE forums since 2008-Nov.
User avatar einar
Administrator
Posts
2270
Karma
5
OS
Usually you have to add it. And as others have said, the feature is quite experimental at the moment (though I assume the developers will work on it for 4.3).


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
User avatar Darkshade
Registered Member
Posts
4
Karma
0
OS
Same problem here - when I add the "perVirtualDesktopViews=true" to the plasmarc file my first desktop works Ok, but the second doesn't display anything except the panel and a black background. The right click menu is missing too.
I tried removing all my activities, adding new ones and restarting but nothing seems to change.
trops
Registered Member
Posts
5
Karma
0
Work perfect on OpenSuse 11.1 with KDE 4.2.62

Code: Select all
kquitapp plasma-desktop


edit $KDEHOME/share/config/plasmarc and add:
Code: Select all
[Global]
perVirtualDesktopViews=true


Then
Code: Select all
plasma-desktop


You have not use compiz as window manager. Enable desktop effects in KDE Control panel.

Image


trops, proud to be a member of KDE forums since 2008-Oct.
User avatar Primoz
Moderator
Posts
859
Karma
1
OS
Nice to hear, but strangely it dosen't work in Kubuntu nor in KDE-neon.

I sometimes feel like using the wrong distro for the best KDE experience...


Primoz, proud to be a member of KDE forums since 2008-Nov.
User avatar bcooksley
Administrator
Posts
18586
Karma
83
OS
This is possibly because the feature is now being implemented for KDE 4.3 ( I think Neon is KDE Trunk? )
As a result the entries in the configuration file are very likely to change.


System Settings and Device Actions KCM maintainer
Image
User avatar Primoz
Moderator
Posts
859
Karma
1
OS
I got it to work in KDE-neon for a while, but then the whole desktop became slow and buggy and crashed. After I log back in there was no plasma any more.
And if I force start plasma-desktop nothing happens. But if I write plasma my normal KDE4.2 desktop appears.
Even after I removed the
Code: Select all
[Global]
perVirtualDesktopViews=true

in my KDE-neon plasma-desktoprc and plasmarc my KDE-neon desktop dosen't come back...
But it's getting near the implementation as I didn't loose the desktops as before my computer just became really slow (hope that that's not due to my hardware and more due to that this option is experimental...)
I think I can get my KDE-neon desktop back with deleting plasmarc and plasma-desktoprc; will report.

Last edited by Primoz on Fri Feb 13, 2009 10:35 am, edited 1 time in total.


Primoz, proud to be a member of KDE forums since 2008-Nov.
User avatar Primoz
Moderator
Posts
859
Karma
1
OS
Nope deleting plasmarc, dekstop-plasmarc and kwinrc (and some other kwin realted rc)
dosen't do the trick. I get the desktop for few seconds the everything just disappears.
Just hope everything will be repaired with next neon update...


Primoz, proud to be a member of KDE forums since 2008-Nov.
yagami
Registered Member
Posts
10
Karma
0
does this still work on kde 4.2.64 ?

i just tryed it and it didnt work :( have the developers disable it ?

thanks
User avatar Primoz
Moderator
Posts
859
Karma
1
OS
yagami wrote:does this still work on kde 4.2.64 ?

i just tryed it and it didnt work :( have the developers disable it ?

thanks

I just tried it in KDE-neon (KDE4.2.63) and it seems not to work.
Probably because it's in development as it was mentioned in few posts ago...
Hoping it will be here soon (at least in KDE4.3)


Primoz, proud to be a member of KDE forums since 2008-Nov.
yagami
Registered Member
Posts
10
Karma
0
since kde 4.2.67, you have an gui to this option.

just zoom out a plasma , and a windows with a checkbox should appear to enable linking activities with virtual desktop

 
Reply to topic

Bookmarks



Who is online

Registered users: Alexa [Bot], anli, Baidu [Spider], Bing [Bot], binro, Exabot [Bot], Ganitzsh, garthecho, Google [Bot], google01103, ken300, koriun, lazyit, Majestic-12 [Bot], Nerdfest, netpalantir, SeaJey, SecretCode, sfepa, vascobasque, W3C [Validator], Yahoo [Bot]