Reply to topic

How to access GMail from Konqueror - not in HTML mode

User avatar R_Rios
Registered Member
Posts
127
Karma
0
OS
No, the newest GMail page is not supported by Konqueror, unfortunately. But we can get rid of that plain, awful HTML interface by using ui=1. Just type on the address bar:

http://mail.google.com/mail/?ui=1

If you want GMail to load this interface by default, this is what you have to do:
- Open "Configure Konqueror..." on the settings menu.
- On the tree view at the left side of the dialog, choose "Browser identification", on the "Web browsing" group.
- Add a new Site Specific Identification like this:
* When browsing the following site: mail.google.com
* Use the following identification: Mozilla 1.7.3

Now you can access www.gmail.com from Konqueror decently.

Note: GTalk chat inside GMail doesn't seems to work.
User avatar widux
Registered Member
Posts
64
Karma
1
OS
Also works here with browser identification "Opera 9.00".


Scholars.de
sidux "aether" KDE 4.2.4
Kernel: 2.6.30-1-686
Box: Lenovo 3000 N100
Graphics: nVidia G72M [Quadro NVS 110M/GeForce Go 7300] - NVIDIA 185.18.14
WLAN: Intel PRO/Wireless 3945ABG

widux, proud to be a member of KDE forums since 2008-Oct.
User avatar Cypher
Registered Member
Posts
28
Karma
0
OS
Doing this crashes my Konqueror every now and then... and if it does not crash, it does not load the page correctly and I end up with a white page.

I really wish we could just switch to WebKit instead of KHTML...


Cypher, proud to be a member of KDE forums since 2008-Oct.
andre_orwell
Registered Member
Posts
181
Karma
1
I've been accessing gmail from Kontact/Kmail using imap whilch I'm quite happy with.
To enable IMAP (or POP) in Gmail:

1. Sign in to Gmail.
2. Click Settings at the top of any Gmail page.
3. Click Forwarding and POP/IMAP.
4. Select Enable IMAP.
5. Configure your IMAP client and click Save Changes.

in kmail go
1. Settings->configure kmail->accounts->Recieving->add. Select IMAP
2. General tab:
Account name: gmail (or whatever you want to call it)
Host: imap.gmail.com
Port: 993 (SSL.. get to that later)
Login: you@gmail.com
3. Security tab:
Encryption - Use SSL
Authentication - Clear text
... or just press the "Check what the server supports" button
4. OK...

If you wan to use the gmail server for sending mail also then:
1. 1. Settings->configure kmail->accounts->Sending->Add
2. General tab:
Name: gmail (or whatever you want to call it)
Host: smtp.gmail.com
Port: 587
Encryption - TLS
3. Advanced tab:
Server requires identification (tick - yes it does)
Login: you @gmail.com
Authentication method: PLAIN
4. OK

Feels like a real mail service :-)


andre_orwell, :-[
User avatar dotancohen
Registered Member
Posts
54
Karma
0
OS
I prefer to simply tell Gmail to ignore the UI declaration:
http://mail.google.com/mail?nocheckbrowser

I got this from a site of Gmail tips: http://gmail-com.com but it seems to be down or something lately.


dotancohen, proud to be a member of KDE forums since 2008-Oct.
User avatar R_Rios
Registered Member
Posts
127
Karma
0
OS
dotancohen wrote:I prefer to simply tell Gmail to ignore the UI declaration:
http://mail.google.com/mail?nocheckbrowser

I got this from a site of Gmail tips: http://gmail-com.com but it seems to be down or something lately.


But Konqueror, last time I tried, supports neither the newest version of GMail, nor the GTalk chat inside it.
User avatar dotancohen
Registered Member
Posts
54
Karma
0
OS
R_Rios wrote:But Konqueror, last time I tried, supports neither the newest version of GMail, nor the GTalk chat inside it.


Works fine for me in KDE 3, but I don't use Gtalk. I will check KDE 4 when I get a chance.


dotancohen, proud to be a member of KDE forums since 2008-Oct.
User avatar sombragris
Registered Member
Posts
15
Karma
0
OS
dotancohen wrote:I prefer to simply tell Gmail to ignore the UI declaration:
http://mail.google.com/mail?nocheckbrowser


All I get is a blank screen when I use this in Konqueror 4.2. Changing browser ID to Opera 9.0 solves the problem using version 1 of GMail.
User avatar Primoz
Moderator
Posts
859
Karma
1
OS
On neither of settings I can't get scrolling with wheel to work.
Strange...
Even though Konqueror is really cool web browser I'm just to used to Firefox so I'll stay with it for awhile. What I really don't like with Konqueror is that I can't see misspellings as I write. Even though I have automatic spell check enabled.

But I'm floating away from topic...
I would like to see the same topic for any other page that dosen't render correctly.
(Men I really hate not knowing how many grammatical mistakes I made, it drives me insane. As I feel that I made them just can't pinpoint the exact mistake)...

Edit: Back on Firefox and I found out that I made only one mistake, not bad B)

Last edited by Primoz on Wed Feb 11, 2009 6:24 pm, edited 1 time in total.


Primoz, proud to be a member of KDE forums since 2008-Nov.
simrnz
Banned
Posts
1
Karma
0
Many Konqueror users actually take it for granted and don't go into micro details of this browser. It actualy does much more than just browsing. More than 98% sites work the same manner as they do on firefox. So I didn't find much difference.
Coming to the topic: when opening gmail, we're redirected to a HTML view that ofcourse not values as much as the AJAXified one coming with the firefox. What you need to do is just to change the browser identification to firefox. To get google mail work best in Konqueror; set the browser identification of gmail.com, mail.google.com and google.com to Firefox. That's it! I've not experimented this with other Google features but gmail and the AJAXy works fine.
Good luck with Konqueror, since it's fantastically quicker and more memory efficient as compared with Firefox....
User avatar s1300045
Registered Member
Posts
39
Karma
0
OS
simrnz wrote:Coming to the topic: when opening gmail, we're redirected to a HTML view that ofcourse not values as much as the AJAXified one coming with the firefox. What you need to do is just to change the browser identification to firefox. To get google mail work best in Konqueror; set the browser identification of gmail.com, mail.google.com and google.com to Firefox. That's it!


This still doesn't do it for me. :-S I still get a blank page after loading the site.


Well, I am lost.
Dekans
Registered Member
Posts
11
Karma
0
OS
With webkit html engine I have the Gmail 2 interface.
But it's still quite buggy


Dekans, proud to be a member of KDE forums since 2008-Oct.

 
Reply to topic

Bookmarks



Who is online

Registered users: alavarre, Baidu [Spider], Bing [Bot], Deevad, Google [Bot], rafaellinuxuser, Sogou [Bot], TheraHedwig, Yahoo [Bot]