Reply to topic

How to disable screensaver when running fullscreen Flash

User avatar unhammer
Registered Member
Posts
53
Karma
0
OS
In short:
Code: Select all
cd ~/.kde4/Autostart
wget https://raw.github.com/unhammer/lightsOn/68066bdaf645abd7f1b8e95fc7ae20b6d11d63fd/lightsOn.sh
sed -i.tmp s/^screensaver=xscreensaver/screensaver=kscreensaver/ lightsOn.sh
rm lightsOn.sh.tmp

then log out and log in again, and enjoy fullscreen flash without having to turn off your screensaver/power management :-)

If you run xscreensaver instead of KDE's kscreensaver, you can remove the sed line, the script supports both. The original script was written by https://github.com/iye (script at https://github.com/iye/lightsOn), I just added two lines to support KDE.
User avatar Dimitrios
Registered Member
Posts
659
Karma
0
OS
it would be very practic if in systemsettings in the screensaver section we had options to disabled the screensaver if something playing in full screen.

I think in 2011 it can be done

Thanks for your tip


«The magic continues...»
http://www.mageia.org
Image
User avatar unhammer
Registered Member
Posts
53
Karma
0
OS
Dimitrios wrote:it would be very practic if in systemsettings in the screensaver section we had options to disabled the screensaver if something playing in full screen.

I think in 2011 it can be done


It can be done if programs are written so they inform the system that they're running fullscreen. Most programs, like (s)mplayer, do this, and the default is then to disable the screensaver in fullscreen. Adobe Flash for Linux doesn't, so we need ugly workarounds like this.
User avatar DrHouse123
Registered Member
Posts
7
Karma
0
OS
It's great. I try it. I think, it's help me. ;)
User avatar google01103
Manager
Posts
6668
Karma
25
I use WiggleMouse it's a small java app & there's a plasmoid to toggle screensaver http://kde-look.org/content/show.php/Sc ... ent=146137


OpenSuse Leap 42.1 x64, Plasma 5.x

User avatar Dimitrios
Registered Member
Posts
659
Karma
0
OS
i cannot make it work in mageia 3
There are both xsreensaver and kscreensaver installed
I tried in a terminal, it detectes the fullscreen, but the screensaver is launched
How could i make it work ?


«The magic continues...»
http://www.mageia.org
Image
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
Have you checked the criteria you use for enabling the screensaver in System Settings? If based on inactivity, are you using the WiggleMouse application mentioned above to cause the mouse to move from time to time during the video?


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar Dimitrios
Registered Member
Posts
659
Karma
0
OS
bcooksley wrote:Have you checked the criteria you use for enabling the screensaver in System Settings? If based on inactivity, are you using the WiggleMouse application mentioned above to cause the mouse to move from time to time during the video?


Yes i set the screensaver to run after 10 minutes of idle
I don't use the WiggleMouse, does it detectes the flash in fullscreen ?


«The magic continues...»
http://www.mageia.org
Image
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
I don't know, I only mentioned it as google01103 did above.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar Dimitrios
Registered Member
Posts
659
Karma
0
OS
I understood that the wiggle mouse avoid the activation of the screensaver but you have to launch it everytime when you watch a video.


«The magic continues...»
http://www.mageia.org
Image
User avatar google01103
Manager
Posts
6668
Karma
25
there's another app you can use called caffeine that resides in the system tray that can be toggled to disable the screen saver. it's a gtk app but works fine, sometimes messes up the tray icons a bit (clicking the panel cashew fixes it), BUT the "activate for flash video" option does not work and it must be toggled. the tray icon changes when it is enabled.


OpenSuse Leap 42.1 x64, Plasma 5.x

RJVB
Registered Member
Posts
79
Karma
0
OS
Why does the "prevent screen lock" hot corner setting not simply work when playing fullscreen flash?
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
Because this likely only controls the screen locking process, and will have no effect on Power Management or a Screensaver - which are completely independent of that.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
RJVB
Registered Member
Posts
79
Karma
0
OS
I was expecting that kind of answer. But the KDE screen saver is controlled through the screen lock functionality; it's presented as one of the forms screen-locking can take. So to call it completely independent is a bit far-fetched IMHO... and as far as I've been able to check the screen indeed won't lock when the corder is in the selected corner. On the contrary, when the cursor is in the "Lock screen" hot corer, the screensaver starts immediately.

Not that I would have anything against an additional hot-corder o)
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
In earlier times the screensaver could also be enabled independently - and was usable without the screen having to be locked. This may explain this behaviour.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], claydoh, Google [Bot], joebuckley, kescher, t., Yahoo [Bot]