Reply to topic

transcode crashes

skylendar
Registered Member
Posts
18
Karma
0
OS

transcode crashes

Tue Jul 30, 2013 4:23 pm
As you know, k3b uses transcode 1.1.5 for ripping the DVDs. However, this util crashes (segfault) after its first pass, on my opensuse 12.3 x86_64. Here is the complete line code, as reported by k3b:

/usr/bin/transcode --nice 19 --log_no_color --progress_meter 2 --progress_rate 818 -i /dev/sr0 -x dvd -T 1,-1,1 -a 2 -j 0,0,0,0 -R 1,/home/sky/tmp/kde-sky/k3b_0.log -y ffmpeg,null -o /dev/null -F mpeg4 -w 1200 -Z 1024x576.

But ok if I choose Xvid as the encoding format. So, the bug seems to be related to ffmpeg. If I add --accel mmx or --accel C (plain code), I get a segfault in libavutil.so.50, that tries to free() an invalid pointer.
User avatar bcooksley
Administrator
Posts
19763
Karma
87
OS

Re: transcode crashes

Fri Aug 02, 2013 10:18 am
This is rather unfortunate. I would suggest attempting to get a newer version of transcode / ffmpeg / libav to see if that fixes the issue. Otherwise, I would recommend filing a backtrace in their respective bug tracker.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
wolfi323
Registered Member
Posts
1121
Karma
11
OS

Re: transcode crashes

Fri Aug 02, 2013 12:14 pm
bcooksley wrote:This is rather unfortunate. I would suggest attempting to get a newer version of transcode / ffmpeg / libav to see if that fixes the issue. Otherwise, I would recommend filing a backtrace in their respective bug tracker.

The crash was caused by an incompatibility between transcode and ffmpeg 0.7.
The transcode package in openSUSE's Packman repository has been fixed in the meantime.

Could you install the new version and retest, please?
skylendar
Registered Member
Posts
18
Karma
0
OS

Re: transcode crashes

Fri Aug 02, 2013 1:56 pm
I'm ready to test the fixed transcode, but the Packman repo still provides the 1.1.5-108.4 version. Where did you upload the fixed version ?
wolfi323
Registered Member
Posts
1121
Karma
11
OS

Re: transcode crashes

Fri Aug 02, 2013 2:00 pm
skylendar wrote:I'm ready to test the fixed transcode, but the Packman repo still provides the 1.1.5-108.4 version. Where did you upload the fixed version ?

It's already in the repo. See: http://packman.links2linux.de/package/transcode

Maybe the mirror you use hasn't synced yet. This can take a few hours depending on the mirror.
But you can download it directly from their homepage if you don't want to wait.
skylendar
Registered Member
Posts
18
Karma
0
OS

Re: transcode crashes  Topic is solved

Fri Aug 02, 2013 3:13 pm
Ok, it works. transcode is still slow, but I was able to rip a DVD on an i5 in 40 mins.

Thx for the fix ;)

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], boudewijn, claydoh, DarkFoss1, edward.81, Gallaecio, Google [Bot], Mamarok, mauromol, moreaupi, Sogou [Bot], TheraHedwig, Yahoo [Bot]