Reply to topic

k3b uses up 4GB of RAM burning bd-r's...

yochanon
Registered Member
Posts
4
Karma
0
I've got k3b setup to use as much RAM as possible when burning. It only allows me to set it at 2GB, and that's it.

Unfortunately it seems to use that up pretty quickly when burning a 25GB BD-R. For example, when it gets (usually) to about 10% done of 100%, the 'software' buffer will begin to go from 100% down to 0% in just a few minutes and the burning will slow down from ~40MB/s to ~12MB/s because it's stuck with only the hardware buffer.

Once in a while at around 60% finished, the software buffer will start to rise again to 100% but within only a few seconds of it reaching 100% it will start to go down again until it's using the hardware buffer again.

Does anyone have any idea(s) what I can do to have k3b use and *keep* the software buffer up during the whole burning process? As it is, 23GB onto a BD-R takes on average ~25 minutes. If it could keep the software buffer up during the whole burn process, it could probably cut that time almost in half. I have 4GB of RAM available, so it's a shame it has to fall so quickly and get stuck using 4MB of hardware buffer.

Slackware 14.0, AMD FX-6300 3.5GHz cpu, ASUS M5A97 LE R2.0 mobo, Crucial Ballistix 4GB DDR3 PC3-14900 RAM, LG WH14NS40 14X Blu-Ray Burner
User avatar google01103
Manager
Posts
6668
Karma
25
maybe the size of the buffer is too high and that causes problems, the defaults are 4mb for cd and 32mb for dvd - have you tried something like 256mb?

if you have 4gb on your system you don't want to allocate 4gb for buffer as the the os would be forced to start using swap


OpenSuse Leap 42.1 x64, Plasma 5.x

yochanon
Registered Member
Posts
4
Karma
0
I can't remember if it was doing the same thing with it set to use a much lower amount of RAM or not. I'll try it and see what happens and let the thread know what happens.
yochanon
Registered Member
Posts
4
Karma
0
google01103 wrote:maybe the size of the buffer is too high and that causes problems, the defaults are 4mb for cd and 32mb for dvd - have you tried something like 256mb?

if you have 4gb on your system you don't want to allocate 4gb for buffer as the the os would be forced to start using swap


Okay...I tried 128MB, 256, 512 and 1GB - all of those settings did the exact same thing as if I had it set at 2GB again, so this didn't work, but thanks for the idea to try.
User avatar bcooksley
Administrator
Posts
19763
Karma
87
OS
Can you use the System Activity (accessible via the graph icon beside the wrench in KRunner) or alternatively KSysGuard to determine if it is K3b itself, or the underlying burning process which is consuming the system memory?


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
yochanon
Registered Member
Posts
4
Karma
0
bcooksley wrote:Can you use the System Activity (accessible via the graph icon beside the wrench in KRunner) or alternatively KSysGuard to determine if it is K3b itself, or the underlying burning process which is consuming the system memory?


I'll try this when I have a full BD to burn and see if I can see anything happening.

 
Reply to topic

Bookmarks



Who is online

Registered users: Bing [Bot], DarkFoss1, franzhall, Google [Bot], philhopkins, Snudl, vinnywright