Reply to topic

problem with burners

roger
Registered Member
Posts
3
Karma
0

problem with burners

Sat Dec 21, 2013 1:34 am
I have two identical burners (Plextor) and k3b he sees one just so I can make copies on the fly. How do I fix it?
Thank You.
User avatar bcooksley
Administrator
Posts
19763
Karma
87
OS

Re: problem with burners  Topic is solved

Sat Dec 21, 2013 9:54 am
What is the output of this command?
Code: Select all
solid-hardware query 'IS OpticalDrive'


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
roger
Registered Member
Posts
3
Karma
0

Re: problem with burners

Sun Dec 22, 2013 12:16 pm
bash-4.2$ solid-hardware query 'IS OpticalDrive'
Object::connect: No such signal org::freedesktop::UPower::DeviceAdded(QDBusObjectPath)
Object::connect: No such signal org::freedesktop::UPower::DeviceRemoved(QDBusObjectPath)
udi = '/org/freedesktop/UDisks2/drives/PLEXTOR_DVDR___PX_810SA_PLEXTOR_DVDR_PX_810SA'
bash-4.2$
User avatar bcooksley
Administrator
Posts
19763
Karma
87
OS

Re: problem with burners

Tue Dec 24, 2013 1:31 am
It appears that as far as UDisks2 is concerned, your system has only one optical drive. Please verify that your system can access both drives (checking for the presence of /dev/sr* entries would be a quick way of doing so, or you could put discs in both drives and see if they are both accessible).


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
roger
Registered Member
Posts
3
Karma
0

Re: problem with burners

Wed Dec 25, 2013 11:54 pm
In fact there is the presence of sr0 and sr1 but if I insert a disk in sr0 I can operate with several software like k3b, Dragon and VLC or manage it with Dolphin, while, if I insert a disk in sr1 I can only operate with Dolphin.
Thank You.
User avatar bcooksley
Administrator
Posts
19763
Karma
87
OS

Re: problem with burners

Fri Dec 27, 2013 4:03 am
I see. I suspect K3b and Dragon Player try to deal with devices (which doesn't work), while Dolphin deals with storage entries (which does work). Are the two optical drives the same make/model by any chance? I suspect you've triggered a corner case/bug in either UDisks 2 or KDE's integration with it.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], JesseWebb, kyrhammer, Majestic-12 [Bot], Yahoo [Bot]