Reply to topic

[FIXED] baloo-file using 100% of a CPU core

User avatar sparhawk
Registered Member
Posts
399
Karma
0
OS
KDE leaking into ~/.xsession-errors is a known bug. Mine was 58 GB at one stage… There is a workaround in the link, although it's been fairly well behaved for me in the last few months (since moving from Ubuntu to Arch).
User avatar sparhawk
Registered Member
Posts
399
Karma
0
OS
vHanda wrote:This is a new issue that has cropped up. It seems we are using newer features of Xapian which are causing the database to get corrupted.

The only way to fix it now is to run -
$ balooctl disable
$ balooctl enable

This will reset the database and restart it.


It looks like it's using 100% of a core again. I left it for an hour or so, then got annoyed and ran these commands. It's been going for another hour…
User avatar Heiko Tietze
Registered Member
Posts
593
Karma
0
OS
New installation: Baloo takes all RAM after a minute and crashes Plasma. Guess there are enough bug reports around ;-).
User avatar sparhawk
Registered Member
Posts
399
Karma
0
OS
I'm not sure if this is related, but when I boot, I get this message, asking for root permission. When I hover over the link, it says "Click to edit org.kde.baloo.filewatch.raiselimit". I've only noticed this in the last week or so, probably since the upgrade from baloo 5.9.2-1 -> 5.13.0-2 on 19 August. This is also a similar time to when I noticed the 100% CPU bug again.

EDIT: I attempted to boot without giving it root permission; I'm not really sure why it should need it. However, the window just kept popping up again.
User avatar davidmar
Registered Member
Posts
9
Karma
0
OS
sparhawk wrote:I'm not sure if this is related, but when I boot, I get this message, asking for root permission. When I hover over the link, it says "Click to edit org.kde.baloo.filewatch.raiselimit". I've only noticed this in the last week or so, probably since the upgrade from baloo 5.9.2-1 -> 5.13.0-2 on 19 August. This is also a similar time to when I noticed the 100% CPU bug again.

EDIT: I attempted to boot without giving it root permission; I'm not really sure why it should need it. However, the window just kept popping up again.


Try this. https://wiki.archlinux.org/index.php/KD ... atch_limit

It's possible this might fix your 100% CPU usage issue as well. It could just be that baloo or some other program isn't able to handle hitting the limit in a graceful fashion.
User avatar sparhawk
Registered Member
Posts
399
Karma
0
OS

Thanks for the suggestion. Unfortunately, after a reboot, I still got the popup.

OTOH, the 100% CPU thing seems to have disappeared by itself.

==EDIT==
I added my home directory to the list of directories for baloo to ignore. That stopped the popup on reboot!
User avatar bkorb
Registered Member
Posts
67
Karma
0
OS
It is unacceptable that *TWO* years after this report that the problem persists. There is no excuse. It should not be necessary for me to go googling around to figure out how to fix up the baloo database or disable the stinky thing. If you can't fix it, then GET RID OF THE DAMN THING. Thank you.
emrebayram
Registered Member
Posts
1
Karma
0
i deleted ~/.xSesion whatever is . then fixed problem
TechieAndroid
Registered Member
Posts
1
Karma
0
Having this same problem.

Running Kubuntu 16.04 LTS 64bit.

After I click to do something I'm normally hit with about 15s of system lag.

baloo_file_extractor is constantly running.

Do I need it? Can I remove it or stop it permanently? I don't need to search for files if indexing is all it does.
ozone
Registered Member
Posts
12
Karma
0
TechieAndroid wrote:Having this same problem.

Running Kubuntu 16.04 LTS 64bit.

After I click to do something I'm normally hit with about 15s of system lag.

baloo_file_extractor is constantly running.

Do I need it? Can I remove it or stop it permanently? I don't need to search for files if indexing is all it does.


Can you check the output of the following command, and if it is updated when you download e.g. a new pdf file from the internet?
Code: Select all
qdbus org.kde.baloo /fileindexer org.kde.baloo.fileindexer.currentFile
Does it return ~/.xsession-errors? If yes, can you check in ~/.config/baloofilerc if the exclude filter contains already .xsession-errors?

Not entirely sure, but I think it is possible to disable baloo_file_extractor specifically by running
Code: Select all
kwriteconfig --file $HOME/.config/baloofilerc --group General --key only\ basic\ indexing true

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Exabot [Bot], Google [Bot], kenj69, Mero Art, metzman, psrch, Sogou [Bot], tosky, Yahoo [Bot]