Reply to topic

Extremely slow login due to Baloo

antonylee
Registered Member
Posts
5
Karma
0

Extremely slow login due to Baloo

Sun May 01, 2016 8:27 pm
My login from SDDM into Plasma (plasma-desktop 5.6.3, plasma-framework 5.21.0 from Arch Linux) is currently extremely slow ( >30s, more than the time needed from booting to reach the login screen!). Disabling baloo (balooctl disable) immediately solves the issue, but of course also disable the possibility of searching for documents quickly. Any suggestions?
User avatar google01103
Manager
Posts
6668
Karma
25
how did you determine that Baloo took 30 secs?

a possible workaround: in systemsettings autostart create and then add 2 scripts
- a startup that enables Baloo (adding a sleep command so that it doesn't get enabled untill KDE is running)
- a logout that disables Baloo


OpenSuse Leap 42.1 x64, Plasma 5.x

antonylee
Registered Member
Posts
5
Karma
0
I found the culprit via bootchart, and checked that disabling baloo solves the issue.

Thanks for the tip. How do I set a logout script? There doesn't seem to be an option in the system config.
User avatar google01103
Manager
Posts
6668
Karma
25
logout option doesn't show until you've added the script

systemsettings ->startup & shutdown -> autostart -> add script -> select script, then select logout



OpenSuse Leap 42.1 x64, Plasma 5.x

antonylee
Registered Member
Posts
5
Karma
0
Got it, thanks.
meightw
Registered Member
Posts
1
Karma
0

Re: Extremely slow login due to Baloo

Wed May 11, 2016 11:48 am
i,m new here.....

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Clancularius, fluca, gammazoid, Google [Bot], satimis, Wolf Icefang, Yahoo [Bot]