Reply to topic

Nepomuk Controller icon

User avatar Teho
Registered Member
Posts
9
Karma
0
OS

Nepomuk Controller icon

Fri Feb 24, 2012 5:30 pm
Is it possible to stop Nepomuk Controller from starting up in KDE SC 4.8 without disabling Nepomuk itself? It's the only tray icon that I just can't find a way how to remove.
User avatar Hans
Administrator
Posts
3281
Karma
20
OS

Re: Nepomuk Controller icon

Fri Feb 24, 2012 5:56 pm
Right click on it -> Quit (to make sure it's not saved in your session).

Then, in System Settings -> Startup and Shutdown -> Autostart, disable "Nepomuk File Indexing Controller".


Problem solved? Please click on "Accept this answer" below the post with the best answer to mark your topic as solved.

Image
10 things you might want to do in KDE | Open menu with Super key | Mouse shortcuts
User avatar Teho
Registered Member
Posts
9
Karma
0
OS

Re: Nepomuk Controller icon

Fri Feb 24, 2012 6:33 pm
Thank you. It was quite hard to discover as I had to add the "Nepomuk File Indexing Controller" entry myself. Hopefully this will be moved to system tray settings in the future.
User avatar Hans
Administrator
Posts
3281
Karma
20
OS

Re: Nepomuk Controller icon

Fri Feb 24, 2012 6:42 pm
Hm, if the entry wasn't there it shouldn't have started automatically to begin with. Did you try to simply quit it before?

The reason it's not in the system tray settings is that it's an application, not a Plasma widget.


Problem solved? Please click on "Accept this answer" below the post with the best answer to mark your topic as solved.

Image
10 things you might want to do in KDE | Open menu with Super key | Mouse shortcuts
User avatar Teho
Registered Member
Posts
9
Karma
0
OS

Re: Nepomuk Controller icon

Fri Feb 24, 2012 7:19 pm
Ok, it seems that the icon appears everytime Nepomuk starts indexing, checking files or something like that and stays in the tray even after it has finished up. So the startup setting didn't have anything to do with it. I guess the case is open again.
User avatar Hans
Administrator
Posts
3281
Karma
20
OS

Re: Nepomuk Controller icon

Fri Feb 24, 2012 7:23 pm
I can't reproduce that, when I quit the application, it's gone even if Nepomuk is indexing.

The normal behavior is for the icon to stay hidden when it's not indexing, are you sure that's not what you're referring to? (It can then be found by clicking on the ^ arrow.)


Problem solved? Please click on "Accept this answer" below the post with the best answer to mark your topic as solved.

Image
10 things you might want to do in KDE | Open menu with Super key | Mouse shortcuts
User avatar Teho
Registered Member
Posts
9
Karma
0
OS

Re: Nepomuk Controller icon

Fri Feb 24, 2012 7:34 pm
I have all system tray icons on "show always" setting. I want to disable Nepomuk Controller competely as I don't need it however I do want to keep Nepomuk running on the background. Now I of course first tried to quit the app and it seems to work for one session but it starts again after relogin.
There's "nepomukcontrollerrc" file on kde configs that has these lines:
Code: Select all
[Notification Messages]
systemtrayquitNepomuk Controller=true
systemtrayquitNepomukin hallinta=true

I tried both true and false but it has no effect. It simply keeps starting up.

EDIT1: It seems that the "quit confirmation dialog" changes the last line to false.
EDIT2: The first line is simply for different locale and doesn't reappear after removing the file.
-> So this settings file seems to have absolutely no effect on anything.
luigi_2k
Registered Member
Posts
1
Karma
0
OS

Re: Nepomuk Controller icon

Mon May 07, 2012 6:28 am
Hi,
this thread is a bit old now, but I was facing the same problem a few months ago and now again after a distribution upgrade.

I Just renamed the .desktop-file of the nepomukcontroller, which disabled the autostart system-wide (controller only, not the nepomuk-service itsself!)

Code: Select all
sudo mv /usr/share/autostart/nepomukcontroller.desktop /usr/share/autostart/nepomukcontroller.desktop.off


This worked on my Kubuntu 12.04 and 11.xx, using KDE 4.8 respectively 4.7

Best regards,
Ludwig

EDIT: I'm not very familiar with .desktop-files but maybe one could create a user-specific nepomukcontroller.desktop, to not disable autostart system-wide and without the need of root-privileges.
User avatar bcooksley
Administrator
Posts
19746
Karma
85
OS

Re: Nepomuk Controller icon  Topic is solved

Wed May 09, 2012 8:42 am
Yes, one can do this fairly easily.

Create a file in ~/.config/autostart/ (creating the folder if needed) named "nepomukcontroller.desktop". Give it the following contents:
Code: Select all
[Desktop Entry]
Hidden=true


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar Teho
Registered Member
Posts
9
Karma
0
OS

Re: Nepomuk Controller icon

Sat May 12, 2012 4:54 pm
Awesome, it works. Thanks.

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Baidu [Spider], Bing [Bot], Exabot [Bot], Google [Bot], google01103, La Ninje, pepedopolous, Sogou [Bot], Soukyuu, Steve T, tavet, veqz, Yahoo [Bot]