Reply to topic

Effect requires opengl 2

rytissavickis
Registered Member
Posts
6
Karma
0

Effect requires opengl 2

Fri Mar 01, 2013 11:55 am
Hello,
I am trying to turn on some effects in Desktop effects and I get this error:
Image

Using propietary AMD drivers, ubuntu version 12.10. How can i fix that? Is some packages missing or what?
sir_herrbatka
Registered Member
Posts
211
Karma
0

Re: Effect requires opengl 2

Fri Mar 01, 2013 3:52 pm
hi,

visit advanced tab and check "use opengl 2".
luebking
Registered Member
Posts
2142
Karma
15

Re: Effect requires opengl 2

Fri Mar 01, 2013 10:22 pm
Depending on the driver (fglrx) and version that won't be possible.
You'll have to use:

KWIN_DIRECT_GL=1 LIBGL_ALWAYS_INDIRECT=0 KWIN_COMPOSE=O2 kwin --replace &

(that's O2 like OpenGL 2) but be aware that overriding the system detection may result in crashy behavior.

On a sidenote: the explosion effect is yet unmaintained and pretty much broken anyway.

 
Reply to topic

Bookmarks



Who is online

Registered users: andreas_k, arcanis, Baidu [Spider], Bing [Bot], buckwangs, cgehman, davidemme, Exabot [Bot], ggael, Google [Bot], google01103, jmacleod, kilianl, La Ninje, molecule-eye, paulv, Przemas, RamonMiranda, Sogou [Bot], tavet, TSDgeos, Yahoo [Bot]