Reply to topic

Can't install QtCurve on KDE Neon with KDE 5.9

aggelalex
Registered Member
Posts
2
Karma
0
I'm quite the "customizer", so I need tools to customize my desktop. Sadly, I can't change the widget styles. I need QtCurve to use widget themes, which is not installable by apt, since I get this error:
Code: Select all
me@mypc:~$ sudo apt install qtcurve
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) qtcurve [ amd64 ] < none -> 1.8.18+git20160112-0cd6aae-1 > ( universe/kde )
Broken qtcurve:amd64 Depends on kde-style-qtcurve-qt5 [ amd64 ] < none -> 1.8.18+git20160112-0cd6aae-1 > ( universe/kde )
  Considering kde-style-qtcurve-qt5:amd64 3 as a solution to qtcurve:amd64 9999
    Reinst Failed early because of qtbase-abi-5-5-1:amd64
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 qtcurve : Depends: kde-style-qtcurve-qt5 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

then I try this, with no luck again :( :
Code: Select all
me@mypc:~$ sudo apt install qtcurve kde-style-qtcurve-qt5
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) kde-style-qtcurve-qt5 [ amd64 ] < none -> 1.8.18+git20160112-0cd6aae-1 > ( universe/kde )
Broken kde-style-qtcurve-qt5:amd64 Depends on qtbase-abi-5-5-1 [ amd64 ] < none ->  > ( none )
  Considering libqt5core5a:amd64 2922 as a solution to kde-style-qtcurve-qt5:amd64 10004
  Considering libqt5core5a:amd64 2922 as a solution to kde-style-qtcurve-qt5:amd64 10004
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kde-style-qtcurve-qt5 : Depends: qtbase-abi-5-5-1
E: Unable to correct problems, you have held broken packages.

And again, with false hopes:
Code: Select all
me@mypc:~$ sudo apt install qtcurve kde-style-qtcurve-qt5 qtbase-abi-5-5-1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package qtbase-abi-5-5-1 is a virtual package provided by:
  libqt5core5a 5.5.1+dfsg-16ubuntu7.2 [Not candidate version]
  libqt5core5a 5.5.1+dfsg-16ubuntu7 [Not candidate version]

E: Package 'qtbase-abi-5-5-1' has no installation candidate


I tried to install libqt5core5a=5.5.1+dfsg-16ubuntu7 using a deb package, in an unfortunate attempt... :'( :'( :'(
I even tried compiling it from source, but I didn't make it.
What can I do??? I realy need to try QtCurve. :( :( :(
Plz Help.
ivanthekdefan
Registered Member
Posts
65
Karma
0
OS
This is a KDE neon issue. I have reported it on bugs.kde.org.
If you absolutely need QtCurve, then my second choice of distro is Fedora KDE.


Hi, I'm Ivan, a competent computer user (which means geek to most). I run KDE neon Developer when it works and KDE neon User when Developer doesn't work.
Hope I helped you with any problems you may have had :)
aggelalex
Registered Member
Posts
2
Karma
0
OK, thank you! Would you please send me the link of that bug report? I will wait for the update patiently, since I'm too bored to reinstall another distro... Thank you for your politeness!
jackdinn
Registered Member
Posts
71
Karma
0
hmmmm, well glad i found this answer but not so glad about this problem. Im on neon 5.11 and its still exactly the same. I too have not got the energy to install YET another distro, this is my 4th this year. I keep finding major problems then starting over with a new distro then i find something else.

I suppose qtcurve is not so much of a deal breaker as the last few distro problems were. Although i'm not 100% sure kmail/Kontact is fixed yet and that's been broken for years and years, but before i get onto really looking at that i did want to just setup the DE. At least i dont have the terrible screen tearing i had with my last (mint 18.3KDE) **frustrated**

Maybe a non debian distro would be a good idea i just recoil at learning a new package manager.

Anyhow, thx.

 
Reply to topic

Bookmarks



Who is online

Registered users: Bing [Bot], claydoh, Donna Turner, Exabot [Bot], Google [Bot], jehojakim2, johnguicar, lueck, Majestic-12 [Bot], ScottBeebiWan, Sogou [Bot], Yahoo [Bot]