Reply to topic

Stop meta key activating host desktop in remote sessions

Fellhahn
Registered Member
Posts
1
Karma
0
Recent windows convert, so apologies if I'm not across a lot of the terminology.

I'm using Kubuntu 19.04 on my laptop, which is a mix of personal and work use.

When at work, most of my job is done in remote desktop sessions (RDC) on Windows servers.

Currently I'm using KRDC as my remote session client, but today I noticed the same problem working on a local QEMU/Virt-Manager VM.

When I am full screened in a remote session, and I press the Meta key (or windows key) in order to open the start menu on the remote session, the key press is being grabbed by my laptop OS. This results in the application launcher opening in Plasma, which pulls the session out of full screen. The key press is also being passed to the remote session, as the remote windows start menu will also open.

This is obviously extremely disruptive, as it affects all meta+ shortcuts, such as opening the run command or explorer.

How can I prevent my laptop OS from intercepting and acting on the meta key presses when I am full screen in a remote session?

I'm not even sure where to start looking for answers, whether it's application specific or a global keyboard setting. I'm also having trouble phrasing the problem in order to search.

Thank you for any help.


P.S. In order to ease my transition from Windows to Kubuntu/Plasma, I have setup several hotkey shortcuts to mimic Windows, as a lot of these key presses are firmly embedded in muscle memory for me. Some examples of mappings I've done:

Meta+R opens KRunner. (Opens run command on Windows).
Meta+E opens Dolphin. (Opens explorer on Windows).
Meta+D minimizes all windows. (Requires enabling a KWin script first. This behaviour is on by default in Windows).

P.P.S.

I am re-posting this question which I also asked at the askubuntu forum here:

https://askubuntu.com/questions/1165082 ... e-sessions
airdrik
Registered Member
Posts
1854
Karma
5
OS
I would consider this a long-standing bug in KRDC and would suggest filing a case to bugs.kde.org (or bump if such a bug case already exists). This seems like a simple oversight to me as I know other similar software such as VirtualBox handle this correctly (in conjunction with a break-out key, usually right-ctrl)


airdrik, proud to be a member of KDE forums since 2008-Dec.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], Majestic-12 [Bot], Sogou [Bot], srgmro33, Yahoo [Bot]