Reply to topic

How can I make the Ctrl+Shift shortcut for iBus to use?

FireHeadMan
Registered Member
Posts
2
Karma
0
On the System settings -> Workspace -> Shortcuts -> Global Shortcuts,
click on any custom shortcut,
then press keyboard shortcut "Ctrl+Shift", it shows "Ctrl+Shift+ ...",
waiting for next key. Something like "Ctrl+Shift+ABCDEFG" is available to use,
But it doesn't trigger the "Ctrl+Shift" itself as a available shortcut.
Press only the "Ctrl+Shift" then release, it doesn't save this shortcut.

I then noticed that in keyboard layout, there is a keyboard shortcut at
System settings -> Hardware -> Input Devices -> Layouts -> Shortcuts for Switching Layout,
there is a shortcut "Ctrl+Shift" to switch to another layout available to choose.

So that seems "Ctrl+Shift" is technically feasible by KDE or system.
How can I use this shortcut in my other software?
The software is IBus, a kind of Linux input method solution.
Use "Ctrl+Shift" to switch to next input method(basically switch on or off)

Last edited by FireHeadMan on Wed Sep 11, 2019 9:42 am, edited 1 time in total.
FireHeadMan
Registered Member
Posts
2
Karma
0
Alright this is not a KDE related issue. Or maybe, I can't recognize this.
To set Ctrl+Shift for iBus(Next input method) shortcut, apply this command to terminal(logged in and no root permission)

$ gsettings set org.freedesktop.ibus.general.hotkey triggers "['<Control>Shift_L']"

Refer to github issue says "It's a limitation of GTK."
https://github.com/ibus/ibus/issues/1966

Hope this would help if someone Googled here in same situation.
It was really strange that this only work if set by terminal command.
Even a valid "Control" + Shift_L key code in iBus preferences interface can't work.
Though it would generate exactally the same result when

gsettings get org.freedesktop.ibus.general.hotkey triggers

A issue that when use Ctrl+Shift+C/V to operate clipboard in terminal emulator(like konsole),
a unwanted input method change will trigger.
But that can ignore. Or even right click the mouse and choose "Copy/Paste".

 
Reply to topic

Bookmarks



Who is online

Registered users: acheshirov, Baidu [Spider], bcooksley, Bing [Bot], Google [Bot], hoxtonhopper, kakosf, kamathraghavendra, Majestic-12 [Bot], Mamarok, P3lor, Snudl, Yahoo [Bot]