Reply to topic

kde-neon activate numlockx

meaux
Registered Member
Posts
5
Karma
0

kde-neon activate numlockx

Wed Sep 04, 2019 1:47 am
Installed kde-neon 5.16.4 user edition I am trying to get numlock=on to start at login
Have tried a number of articles but none working
Need suggestions where to begin finding a workable solution
User avatar Mamarok
Manager
Posts
5509
Karma
16
OS

Re: kde-neon activate numlockx

Wed Sep 04, 2019 9:03 am
Look in System Settings -> Input Devices -> Keyboard. Not hard to find.


Currently running Kubuntu 21.04, Plasma 5.21.4, Frameworks 5.81.0, Qt 5.15.2, kernel 5.11.0-16
FWIW: it is always useful to state the exact Plasma version and distribution when asking questions, makes it easier for us to help ...
meaux
Registered Member
Posts
5
Karma
0

Re: kde-neon activate numlockx

Thu Sep 05, 2019 12:17 am
The suggestion from system does not work
Tried setting it numerous ways will not turn numlock on
User avatar Mamarok
Manager
Posts
5509
Karma
16
OS

Re: kde-neon activate numlockx

Thu Sep 05, 2019 7:38 am
Oh, sorry, reread your post, turning Numlock on on login needs to be done in the BIOS settings, before the X Server starts. My previous suggestion only works once you are logged in.


Currently running Kubuntu 21.04, Plasma 5.21.4, Frameworks 5.81.0, Qt 5.15.2, kernel 5.11.0-16
FWIW: it is always useful to state the exact Plasma version and distribution when asking questions, makes it easier for us to help ...
meaux
Registered Member
Posts
5
Karma
0

Re: kde-neon activate numlockx

Thu Sep 05, 2019 8:21 pm
There is not any item in Bios to turn numlock on
also tried adding to sddm not working in that file
Any other suggestions will be appreciated
jmacleod
Registered Member
Posts
40
Karma
0

Re: kde-neon activate numlockx

Fri Sep 06, 2019 1:43 pm
One of several minor annoyances - NumLk does not switch on at llog-in even tho System Settings is set accordingly.

Likewise Falkon - always starts up set to use Kwallet as password manager despite it being set to text file in Preferences every time. Even more annoying since Kwallet is disabled.

Apologies but used KDE for years and it's simple things like this re-occuring become major gripes.
agustinods
Registered Member
Posts
1
Karma
0
OS

Re: kde-neon activate numlockx

Fri Oct 16, 2020 11:12 pm
I was have the same exactly the same problem, and then of an exaustive search i find the solution (works for me) in this article:

https://wiki.archlinux.org/index.php/SDDM

You only have add a line "Numlock=on" in the archive kde_settings.conf in the folder /etc/sddm.conf.d/ with sudo in the section [General]
and reboot, thats all. :) :)

 
Reply to topic

Bookmarks



Who is online

Registered users: alicehere, Baidu [Spider], Bing [Bot], Google [Bot], Khym Chanur, Majestic-12 [Bot], pentaxis, Section_8, Sogou [Bot], Yahoo [Bot], zebulon, zilexa