Reply to topic

Dual monitor refresh rate is restricted to 60Hz

Yotsuya
Registered Member
Posts
2
Karma
0
The problem: I have one 144hz monitor (via DisplayPort) and one 60hz (via DVI), both have the same resolution. When both are connected, the 144Hz one renders everything in 60fps, which I can observe on https://www.vsynctester.com/
As soon as I unplug the 60Hz one, 144Hz now works correctly and renders desktop and programs in 144fps. Here's the proof: https://imgur.com/a/2tUZu9l

What I tried:
1. Settings in kwinrc:
Code: Select all
[Compositing]
AnimationSpeed=1
Backend=OpenGL
Enabled=false
GLCore=true
GLPreferBufferSwap=n
GLTextureFilter=2
HiddenPreviews=5
OpenGLIsUnsafe=false
WindowsBlockCompositing=true
XRenderSmoothScale=false
MaxFPS=144
RefreshRate=144

2. Manually setting resolution and refreshrate for monitors in Nvidia Settings and enabling "Force Full Composition Pipeline" (saved config to /etc/X11/xorg.conf)
3. Disabling compositor entirely
None of these worked, im still capped to 60fps when using both monitors. As I said, just using 144hz one is fine and everythign works correctly.

My software:
Arch Linux
KDE Plasma 5.17.13
KDE Frameworks 5.64.0
Kernel 5.3.13
GPU: Nvidia GTX 960 (440.36 driver)

Please send help, Im desperate.
Yotsuya
Registered Member
Posts
2
Karma
0
Update: I managed to workaround the problem.
I basically turned on multi-monitor support through iGPU in BIOS and it works fine now.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], claydoh, Google [Bot], Majestic-12 [Bot], mheyes, Sogou [Bot]