Reply to topic

Sometimes brightness controls stop working

mercurial
Registered Member
Posts
27
Karma
0
For some reason my brightness controls on my laptop sometimes don't work upon logging in. I think it's because the Power Management Service doesn't load upon startup. It is always fixed by rebooting, however it would be good if I could fix it without rebooting.

Any help? Thanks.
steinhr
Registered Member
Posts
12
Karma
0
OS
I have, regularly, what I think is a similar issue. It is my impression--just to get it said somewhere on this forum--that the main Neon KDE Linux developers ought to go through the Power Management and Brightness Controls and other settings, such as how long to wait before logging out--and brush it up considerably [for instance, I have yet not found a way to prevent it from going back to login screen after a quantity of minutes--regardless of System Settings as to power/brightness/display/logout controls--unless a video is playing, or something is showing in fullscreen mode].

A workaround that at least for me works, and which re-starts brightness controls suitably--and that puts brightness into the control of the user again--is this: unplug power, and plug it back in. [Btw: I am using version 5.18.4].
mercurial
Registered Member
Posts
27
Karma
0
;D LOL, never thought of doing that! I'll try it the next time it happens. Thanks for the tip.

steinhr wrote:I have, regularly, what I think is a similar issue. It is my impression--just to get it said somewhere on this forum--that the main Neon KDE Linux developers ought to go through the Power Management and Brightness Controls and other settings, such as how long to wait before logging out--and brush it up considerably [for instance, I have yet not found a way to prevent it from going back to login screen after a quantity of minutes--regardless of System Settings as to power/brightness/display/logout controls--unless a video is playing, or something is showing in fullscreen mode].

A workaround that at least for me works, and which re-starts brightness controls suitably--and that puts brightness into the control of the user again--is this: unplug power, and plug it back in. [Btw: I am using version 5.18.4].
visone
Registered Member
Posts
26
Karma
0
OS
I have the same problem when using nvidia card, I have dual graphics amd/nvidia. I make a script to do so while it fixed.
This is the command to change brightness
xrandr --output eDP1 --brightness 0.75
First you need to know the name of you screen, with xrandr you'll know. eDP1 use to be for laptop's screen, check the name or yours.
The you can do something like this on a text file
#!/bin/bash
echo=" choose brightness <--0/1-->" # this is the title you'll see
read bright # save the valor you want to set
xrandr --output screen-name --brightness $bright # command to set brightness with the valor you set, like 0.75

Save it like bright.sh and put it on you home, go to you home in the terminal and run chmod +x bright.sh so you can exec it. If you wanna use it just run this in terminal ./bright.sh

#Optional--- easy way to do it
I make an alias to run the script with just the word bright o any other word you want, just run this
echo="alias bright='/home/user/bright.sh' >> .bashrc" && source .bashrc

I hope it work for you!

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], claydoh, fozziebear, Google [Bot], idriskalp, Sogou [Bot], spoontex, tymond, visone, Yahoo [Bot]