Reply to topic

Issue defining shortcuts (french keyboard)

pepito
Registered Member
Posts
1
Karma
0
I'm using Garuda's distro and the latte-dock on the KDE plasma desktop, I'm french which means I'm using "azerty" keyboard layout.
When I use the GUI to change my shortcuts in
shortcuts > Latte Dock > New instance for Entry 1

I press "Meta+é". "é" is the special character of the "2" key (above "a" and "z")

I don't know why but the system auto correct it by entering "É" instead (maybe for design purposes ?). Therefore the shortcut becomes "Meta+É" instead of the "Meta+é" I just entered.
The problem is that the "É" key doesn't exists ! Thus the shortcut is not working.

I thought : "ok it's not a problem, I'm gonna edit the config file".
Thus I went and edited
~/.config/kglobalshortcutrc

Saved the file.
I check the GUI : nothing changed. I try the shortcut : not working

Apparently for the changes to be taken into account you have to restart kglobalaccel (see the last comment here : https://www.reddit.com/r/kde/comments/6 ... fig_files/)

So in a terminal I typed
kquitapp5 kglobalaccel && sleep 2s && kglobalaccel5&

Which automatically updates my kglobalshortcutrc file and put back the É instead of the é character !

I'm new to linux and I'm trying to troubleshoot this issue for 3 days already, can someone help me ?
guilhems
Registered Member
Posts
3
Karma
0
Hello, I'm having the exact same problem : AZERTY layout binds me "É" instead of "é", so the shortkey doesn"t work. Is there a way to prevent the uppercase ?
joedunkelheit
Registered Member
Posts
1
Karma
0
I am having the same issue. Is there any workaround ?
gigaturbo
Registered Member
Posts
1
Karma
0
Any news? Same problem here, it seems there is a problem with plasma shortcuts and "azerty" keyboards
dzon
Registered Member
Posts
282
Karma
3
I use azerty ( B ) too but I can't reproduce the issue. Not sure if there's a difference in French or Belgian azerty, which mine is set to. As a sidenote, you could use the longpress function which pops up a character option window ( like typing on a smartphone) but that function seems to kill a few other characters on azerty. A better option, as long as the issue isn't solved (or overall, instead of having to use the meta or other third level key at all) is to install kcharselect. It has a gnome counterpart as well, but since you're on kde...
https://imgur.com/a/qeE2yNa Loads of characters, bookmark functions.... It doesn't solve the main problem, but..


This realm's name is Maya. And she speaks Hertz. But Ahamkara makes a fuzz about it.

 
Reply to topic

Bookmarks



Who is online

Registered users: Bing [Bot], desktopecho, Google [Bot], Ilpo Kantonen, lotiruto