Reply to topic

Powerdevil, Lithium, Power Management

User avatar akoskm
Registered Member
Posts
135
Karma
0
OS
Hi!
How it works?!
They are overriding each-others settings? In System Setting I have 1 profile - Powersave. In lithium I have 4. Ahh and Display power control...
How to apply these profiles? Is it working or I need to install KPowersave and delete Powerdevil and Lithium?


User avatar sayakb
Administrator
Posts
1973
Karma
12
OS
You may have to remove all other power managers, but powerdevil to avoid config clashes. I once had clashes between guidance and powerdevil settings (screen brightness and button actions). So powerdevil (Power Management in System Settings) should do alone.


User avatar akoskm
Registered Member
Posts
135
Karma
0
OS
LinuxIsInnovation wrote:You may have to remove all other power managers, but powerdevil to avoid config clashes. I once had clashes between guidance and powerdevil settings (screen brightness and button actions). So powerdevil (Power Management in System Settings) should do alone.


Okay! Just removed the Lithium plasmoid. I hope it'll work now.
Thanks!


User avatar akoskm
Registered Member
Posts
135
Karma
0
OS
I'm checked Let PowerDevil Manage screen powersaving in System Settings -> Power Management, but PowerDevil doesn't want to manage my screen powersaving. :)
Under profiles in screen section Enable DPM is checked out, standby, sus, power off all set to 7 minutes but it doesn't work.


User avatar bcooksley
Administrator
Posts
19763
Karma
87
OS
Power Devil usually refuses to do anything if you have any other power managers running. on OpenSuSE, there is a background service "powersaved" which has no GUI.

check to see if your distro has something like that. Once you have switched it off, you will need to restart PowerDevil in System Settings > Service Manager


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar akoskm
Registered Member
Posts
135
Karma
0
OS
bcooksley wrote:Power Devil usually refuses to do anything if you have any other power managers running. on OpenSuSE, there is a background service "powersaved" which has no GUI.

check to see if your distro has something like that. Once you have switched it off, you will need to restart PowerDevil in System Settings > Service Manager


I'm checked that and my powersaved daemon isn't running. It's disable also in Runlevel Editor in YaST.


User avatar bcooksley
Administrator
Posts
19763
Karma
87
OS
By default there are a few profiles.... Is the right one activated? Aggressive Powersave is selected when you open "Edit Profiles" first I believe.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar akoskm
Registered Member
Posts
135
Karma
0
OS
bcooksley wrote:By default there are a few profiles.... Is the right one activated? Aggressive Powersave is selected when you open "Edit Profiles" first I believe.


For me Performance. This is the profile what I'm first added to the profile list.
Enable DPM checked out. Standby, susp, power off set to 5, 7, 10 min. And the Let PowerDevil Manage screen powersaving is also enabled. On the Capabilities page DPMS is OK.


User avatar cybertaz
Registered Member
Posts
34
Karma
0
There is bug report about this: https://bugs.kde.org/show_bug.cgi?id=165368

There are problems with power management and KDE4 (or screensaver or ??).


cybertaz, proud to be a member of KDE forums since 2008-Oct.
User avatar akoskm
Registered Member
Posts
135
Karma
0
OS
cybertaz wrote:There is bug report about this: https://bugs.kde.org/show_bug.cgi?id=165368

There are problems with power management and KDE4 (or screensaver or ??).


I can't figure out anything about this bug report, except one thing: it's buggy. But I knew that before. It isn't depends on screen saver's configuration. It could be enabled or disabled the DPMS in PowerDevil isn't working.

Last edited by akoskm on Thu Dec 18, 2008 10:53 pm, edited 1 time in total.


User avatar cybertaz
Registered Member
Posts
34
Karma
0
The work-around in the bug report (disable screensaver) worked for me. My screen now just blanks after the appropriate time.

Have you tried that?


cybertaz, proud to be a member of KDE forums since 2008-Oct.
User avatar akoskm
Registered Member
Posts
135
Karma
0
OS
cybertaz wrote:The work-around in the bug report (disable screensaver) worked for me. My screen now just blanks after the appropriate time.

Have you tried that?


Yes, I'm tried almost everything. Just to compare our configuration:
Code: Select all
systemsettings: - Desktop
            |
            + Screen Saver > Start automatically : Disabled;
         - Display
            |
            + Power Control > Enable Display power management : Disabled;

         - Power Management
            |
            + General Settings > Let PowerDevil manage screen powersaving : Enabled;
            + Edit Profiles
               |
               + Performance (custom profile)
                  |
                  + Screen > Enable Display power management : Enabled;
                        > Stand by, suspend, power off | after 1, 2, 3 min;

Last edited by akoskm on Thu Dec 18, 2008 11:38 pm, edited 1 time in total.


User avatar akoskm
Registered Member
Posts
135
Karma
0
OS
No answers?!
Any suggestions?
Is this picture confusing? I can post another one. :) But that will be in xml! ;-) haha


User avatar cybertaz
Registered Member
Posts
34
Karma
0
in systemsettings->Display->Power control->Enable Display Power Management->ENABLED

For me this works.


cybertaz, proud to be a member of KDE forums since 2008-Oct.
User avatar akoskm
Registered Member
Posts
135
Karma
0
OS
Okay, that's also working for me. But here you are setting the DPMS globally. I need to get work those profiles with custom timeout in PowerDevil.
BTW, thanks!



 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], claydoh, dbergstein, dfoskett, gfielding, ghevan, Google [Bot], gvigroux, Jay 5gzmn, Snudl, Sogou [Bot], Sugarmaster, TheraHedwig, TristanDee, tymond, victus_maestro